Jump to content
Corsair Community

Corsair Hydro Series 7289 USB Device


Recommended Posts



I got an H100i, AX760i, Link Comander and Cooling Node about a year and a half ago. Unlike many people it worked perfectly from the get go on Windows 7. I upgraded to Win10 late last year (complete reinstall) and I was left with a yellow splat in device manager against a "Corsair Hydro Series 7289 USB device", annoyingly it would also constantly ping a Windows sound indicating Hardware Removal. Tried uninstalling and reinstalling various version of Link to no avail so just lived with it.


I have just upgraded my hardware (new M/B, SSD, CPU) and reinstalled Win10 and the same yellow splat is in device manager. Does anyone know what it is and how to get rid of it?





Link to comment
Share on other sites

If you have an old Link Commander you may need to use Device Manager to update the driver. Have look towards the end of http://forum.corsair.com/forums/showthread.php?p=777371 for how to do this.


CL 4.2 does not support the old commander though, but I have no idea as to why as I think it's trivial to support as my code is < 40 lines of C to do this.


You should add your PC specs to your profile.

Link to comment
Share on other sites

Many thanks, that seems to have fixed it.

hydros7289.inf should be changed for the H80iGT + H100iGTX to match the USB REV so it does not get used for the old Link Commander. See http://forum.corsair.com/forums/showthread.php?p=834615.


Good, but you should not need to do this.


:brick: It's about time Corsair fixed hydros7289.inf and they need a :asskick:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...