Jump to content
Corsair Community

h80i GT various issues after two days of working fine


Recommended Posts

I recently installed an h80i on my new build, and it was working fine for a few days of constant use; however, it now seems to have an array of issues.


Firstly, my temps are crazy high. I'm idling @ close to 100 Celsius. I've remounted twice, which has worked very briefly but after about 15 minutes was right back to where it was. The second time I was idling @ around 80 Celcius for an hour before reaching 100 again.


Second, I can't connect the cooler to link. I've reinstalled link numerous times, tried different usb headers, using external USB ports, and reinstalling drivers. I do get error 43 on what I know is the correct usb in device manager.


Edit: making specific mention that both my pumps and fan do not show up in devices or anywhere else in link.


Third, my radiator fan is maxed out. I have no doubt that this is due to the extrem temps, but it's worth noting. I also have no reason to think that my single radiator fan setup is the issue, I've tried the configuration with a second fan with no change, and as I mentioned, it worked for multiple days before the issue occurred.


I can't seem to find any issues running into all of the same problems, just one or maybe two of them. Neither of the tubes are ever hot when felt, just the same temp as my internal temps (maybe this is considered hot?). Also I've seen a few threads about changes to registry to show the h80i in link, but I don't have those folders in my registry.


I'd be greatful for any advice before I think about an RMA.


Setup image: http://i.imgur.com/a2ktIwn.jpg

Can supply more images if needed.


Edit: BIOS shows my cousin fan speed at 0rpm. I imagine this means my pump isn't working at all.

Link to comment
Share on other sites

The first thing you need to do is figure out whether your CPU temps are actually in the 80-100C range or whether this is some sort of software/senor conflict gone horribly wrong.


  • At 100C idle I would expect a thermal safety shutdown. You didn't mention this happening, so I am wondering where that data comes from? It seems LINK is not operational. Fully exit the program and use something else (HWMonitor, HWinfo, anything) to check CPU temperatures.

  • You mentioned the tubes don't feel hot. If the pump is not running or water flow blocked in some other way, the tubes (or at least one) should be alarmingly warm to the touch.

  • If the temperatures are genuine and tubes are not scalding hot, you may have a contact problem between the block and CPU. It's possible it slipped a little on one of posts or was never completely on. I am not banking too much on this theory, but we'll have to wait and see.


Even if you can't read pump speed, you should be able to a finger or two on the block and feel the mechanical vibration. The light is on suggesting you have power. Don't worry about fans and fan speed. These kinds of temperatures have nothing to do with your fan configuration. The LINK and USB device configuration will require some fiddling, but I don't see a reason to start that until we can verify your unit is operational.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...