Jump to content
Corsair Community

Macro problem


Recommended Posts

Hello... its been a month and a half that i purchased the corsair strafe RGB keyboard but since then the macros aren't working at all... I started with a simple one like assigning to F4 key the quit program keystroke ( Alt + F4 ) but even this doesn't work... i have tried reinstalling the program more than ten times. ( launching programs and media keys reassignment works ) Literally i don't know what else to try... yesterday for some unknown reason the macros started to work ( i pressed by accident the F4 and the window that i had open closed ) but after i restarted my computer i had the same result... no macros are working. :(: :(:


[Also when i press a macro key the program crashes, if i double click it to open it doesn't start and i need to terminate it from the task manager and reopen it to work again. ]


Any suggestions would be appreciated !!

Link to comment
Share on other sites

no unfortunately no... today it started to work again at some random time of the day... i heard the sound of a usb connect/disconnect and then it started to work again... what can it be ? i tried different usb slots and i have plugged both usbs at usb 3.0 ports... i am afraid that if i restart again my computer it will stop working again :(


Also this is a picture from device manager when the macros on keyboard doesn't work. Is this normal ? Shouldn't be the name of the keyboard in one of those two ? Can anyone upload a screenshot of his device manager with a corsair keyboard on ?


Link to comment
Share on other sites

It seems that i fixed the problem. ( at least for now ) it has been 2 days in a row that everything works fine. For anyone in future that might have the same problem this is what i did:


1) Unplugged keyboard

2) uninstalled corsair CUE

3) uninstalled any remaining drivers left under keyboards tree in device manager

4) restarted computer

5) installed corsair CUE

6) plugged in the keyboard and waited to be recognized by the software


in my case i believe there was a conflict between my previous keyboard drivers and my new drivers. I thought that uninstalling the old program would leave any (old ) drivers. I was wrong. Thanks for everyone that helped!

Link to comment
Share on other sites

  • 4 weeks later...
You should be seeing something like "Corsair virtual composite device..."/something similar in Device Manager. if you do not see that in any of the trees, it's probably the reason why the macros are not working.



This is what i am getting and despite my efforts i can't seem to be able to fix it... :[pouts: :[pouts:


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...