Jump to content
Corsair Community

Discuss Link v4.2.0.162 here


Recommended Posts

  • Administrators

This will be the official discussion thread for Link v4.2.0.162.


If you'd like to report a bug, please respond to this thread in this format:

  • Version of your Link software. NOTE: If you're not using v4.2.0.162, please install it and see if the bug has been fixed.
  • What version of Windows you're using.
  • Summary - One line / sentence explaining the issue
  • Detailed description of the issue - This part can be as long as you want. It should be detailed enough so that we can clearly identify the issue and attempt to replicate it.
  • Attach photos of the issue to the post that help #4.


01/26/2016 - Corsair Link Software Update Version



  • First Public Release for v4!

Link to comment
Share on other sites

  • Replies 191
  • Created
  • Last Reply

cooler H100i

windows 10 pro 64 bits build 11102. (insider)


I installed that version and work ok. I had to change the fan and installed the Noctua NF-F12 PWM 120MM Ultra Quiet Cooling Fan 300-1500RPM 93.1M3/H 22.4DBA 4-PIN PWM

At boot I receive very fast message then the corsair link windows appeared and work ok. Is there a fan manufacturer check at start ?

Link to comment
Share on other sites

I wonder if Corsair knows that there are no links on the forums pointing back to the download page for Corsair Link v4?




WOW!!! Talk about a huge step backwards!!


Whose bright idea was it to remove the ability to punch in numbers for the fan speeds and force users to plot points on a graph. Do they know how much of a PITA it is to try and configure a push pull setup when both fans must be the same speed. Before it was as easy as punching in temperature and what speed I want the fans at that temperature, now its a guestimate as it is very difficult to get a even value on the graph.


Gone is the ability to resize the window like a normal window. You have to be an eagle eye to notice the lower right hand corner


For some odd reason my H80i is showing a fan connected to port 4 when I only have fans connected to ports 1 and 2.



Link to comment
Share on other sites

Guys i upgraded to Clink 4.0 but now it cant find the PSU a AX1500i and the Led on the PSU isnt moring blinking red it stays green.

Anyone has the same issue or is it only my PC


I have the same problem. My AX1500i is also not detected. It is connected by usb directly.


Also the fans/rpm of my 3 980tis are no longer showing.

Link to comment
Share on other sites

As far as CL4 development goes, like I said, it's being rearchitected by a solid team. I can't say much more than that. I suspect a lot of your concerns will be alleviated by then and if they aren't, well, we'll keep working.

I am sorry to tell you that your suspicions are incorrect. As of 09-Feb-2016 since the release of CL4 of 26-Jan-2016 there has not been much if any help from Corsair staff on this forum or comments on the issues raised. On the 11-Feb-2016 I spotted the 4 posts from Corsair Chris which is rather less then there needs to be and says a lot about Corsairs commitment to CL4.

  1. There don't seem to be any detailed release notes. What is their URL please?
  2. Not supporting the old Commander is a strange decision given it takes SIV < 40 lines of C to support it.
  3. When started it CL4 takes 20 -> 30 seconds before all the hardware is reported on the home screen. This is far longer than it should be. SIV took 1.67 seconds so why does CL4 take over 10 times as long? CL4 log attached.
  4. When I first ran CL4 it set default values in my hardware rather then reading the current settings as CL3 does. This is a PITA as it meant I needed to set them all manually. Is this a Bug or a Feature please?
  5. The Windows + CL4 version information should be displayed. I feel either on the menu line right or bottom right of the screen would be good. I feel Windows 7 x64 Build 7601 + CL would be good. The build is needed for W10 as TH1, TH2 and RS1 are very different. Quite often members post CL4 screen shots and I have to almost guess which system they are from.
  6. When I switch from [Home] to [Configure] it takes about 15 seconds when I have all my CL hardware connected. This is far longer than is acceptable.
  7. I suspect using TCP as the transport between the service and GUI could be a factor in this and feel this was rather a poor design decision. I suspect there others.
  8. When the CL4 screen is moved to the left of the main desktop it instantly jumps back to the main desktop which is at 0,0. Moving it to the right is OK. This is a regression from CL3.
  9. The service.log log file seems to be always created and I can't find out how to disable this. It could also end up being rather large, mine was 84MB when I deleted it and I suspect those who run CL4 24/7 may end up with several GB.
  10. If I close down and restart CL4 the initial screen size is changed to the small default size when I expected it to be as I had set it which was the case with CL3. It also is on my default screen rather than where I last positioned it.
  11. When I close down CL the cpuz138 service is not stopped and deleted. This is a regression from CL3. Given I have reported this before how come it was not picked up in regression testing (it is considered good coding practice, when a bug is located and fixed, to record a test that exposes the bug and re-run that test regularly after subsequent changes to the program)?
  12. hydros7289.inf should be fixed such that H80iGT + H100iGTX + H110iGTX as reported as such by Device Manager to bring them into line with the HydroSeries H115i, etc.. as this would avoid confusion such as http://forum.corsair.com/forums/showthread.php?p=837390.
  13. hydros7289.inf should be changed for the H80iGT + H100iGTX to match the USB REV so it does not get used for the old Link Commander. See http://forum.corsair.com/forums/showthread.php?p=834615.
  14. hydros7289.inf should be updated to support the Corsair Link™ USB Dongles so only one driver is needed. Both siusbxp.inf and hydros7289.inf specify the same SIUSBXP service, so having both is silly.
  15. CL4 Causes High DPC Latencies, see http://forum.corsair.com/forums/attachment.php?attachmentid=24076&stc=1&d=1453907616.
  16. On [Home] all the same type of devices have the same name, but on [Configure] they have #1, #2, ... numbers. I feel there should be numbers on [Home] so it's clear which is which.
  17. On the Devices panel all 4 x CLCC have exactly the same description, so it's tricky to know which is which. Same for the 2 x RM PSUs + 3 x Lighting Nodes and I suspect every other device type.
  18. The two Corsair RM-Series C-Link Adapter should be RM 1 and RM 2.
  19. The Temp, Fans and LEDs headings on the CLCC + Cooling Node should be removed and there should just be a heading of CM 1, CM 2, ... CN 1. This will make them the same as the H100i so all the items are consistent.
  20. The three Lighting Nodes should be LN 1, LN 2 and LN 3.
  21. CL4 reports both my AX1500i + AX760i at the same time, though I can't seem to get detailed information for both at the same time. The Power and Efficiency should be on the Home screen, better still I should be able to select what is on the Home screen.
  22. CL4 should use Temp rather than Temperature as is the case everywhere else.
  23. CL4 will report my AX760i when I USB connect it, but not my AX1500i. I assume the CL4 code only checks for a PnP ID of VID_1B1C&PID_1C00 when it also need to check for VID_1B1C&PID_1C02 and maybe VID_1B1C&PID_1C01.
  24. CL4 incorrectly reports my BLT4G3D1869DT2TXRG PC3-14900 DIMMs as PC3-10700.
  25. Having the Crucial Technology heading eight times is pointless. It should only be there once or when it changes as is the case on my Dell 490. On my HP DL580 G5 it has 4 x Micron Technology PC2-5300 headings and fails to mention Samsung and Hyundai at all. Having thought about this I feel CL4 should just have a heading of PCn-nnnn and default names of Temp 1 to Temp nnn as if a user wishes to get maker information they would do better to use a program designed to provide this. The cute option would be to have a Tool Tip similar to the one I have in SIV.
  26. CL4 is missing the Dell 490 section and the motherboard temperatures + fans + VCPU information.
  27. Why is CL4 reporting the WDC WD1600JS-00NCB1 temperature twice? I feel this is either poor ergonomics or a bug.
  28. CL4 is reporting Motherboard when it should be HP DL580 G5 and all the SMSC SCH4307 sensor information is missing.
  29. The per X7460 % CPU used totals are incorrect by at lest an order of magnitude. From Task Manager it's obvious that it can't be 30% let alone 68%. I also noted that the % only changes for the first Xeon. Note the system has 3 CPU Groups with 8 CPUs in each Group.
  30. The Xeon X7460 core temperatures are correct for the first 8 cores and the remaining 16 are all reported as 36.0°C which is clearly incorrect.
  31. Having the Cores ordered 1 10 11 12 2 3 4 5 6 7 8 9 is silly and different to how Microsoft order things on Windows 10. There is also the same silly ordering on the AX1500i PCIe outputs.
  32. The package temperature for my Xeon E5-2696 v2 (Ivy Bridge-EP) is incorrect , see http://forum.corsair.com/forums/showthread.php?p=839321.
  33. None of my CSMI RAID or USB attached disks are reported. The CMSI protocol is well defined and for CL4 to fail to support it is rather poor.
  34. Only 4 of my 6 motherboard fans are reported. I have been waiting 14 months for this to be fixed.
  35. My H80 is reported as a Cooling Node, same for the H100.
  36. The Devices panel can't be resized and I suspect there are many others. Any panel with a scroll bar should be resizable.
  37. I can't seem to set a PWM % of < 40 %. How do I enable "advanced" mode so I can do this?
  38. I can't find how to configure a Custom Curve to use multiple temperatures. Is this possible?
  39. I can't find how to setup a Custom Curve for my AX1500i or AX760i PSU Fans. Is this possible?
  40. I can't find how to setup a Custom Curve for my H80iGT Pump. Is this possible?
  41. I can't find how to select the temperature source for my H80iGT Fan. Is it still limited to just the H80iGT Cooler Temperature?
  42. I can't find out how to update CoolIT firmware. Is this possible?
  43. I can't find any CLCC or any other firmware, was expecting (wishfully hoping for) a new version that fixed the long standing bugs and added support for 0 % PWM to stop the fan.
  44. My RM PSUs are not available on [Configure]
  45. My Motherboard Fans are not available on [Configure]
  46. My GTX 980 Fans are not available on [Configure]
  47. The Total % is not available on [Configure]
  48. Only my AX1500i + AX760i PSU Temp and fan speed are available on [Configure]. All the PSU information should be, epically so for the Power and Efficiency.
  49. On [Configure] I should be able to dock items and then move them all as a group as having to move each item of a CLCC one at a time is a PITA.
  50. Setting up push-pull cooler fans to use the same Custom Curve is at best tricky. There should be a facility to group fans together then use the same CC and also to clone an existing CC to a different fan/pump.
  51. When I exit CL4 it sometimes fails to release a semaphore. This is caused by both poor code and design as it should use a Mutex rather than a Semaphore because a Mutex would be implicitly released on thread exit by the Windows thread cleanup.
  52. Worst of all CL4 does not correctly implement Global\Access_CorsairLink named mutex support :mad:

AIDA64 may have difficulty playing nice with Corsair Link running at the same time. This is something we're addressing in a future version.

CL is a future version so why has this not been addressed?


OK, I am being rigorous, but I would expect a "solid team" to be equally if not more rigorous. The MB and GPU fans not being available on [Configure] is one of the worst oversights I have ever come across :nodding:. I did not really try to find issues, but when I noted them I checked what happened on my test systems that I use to test SIV and found yet more issues. Even I was surprised with the number of issues I found :ummmm:.

I currently suspect CL4 had to be released to support the H115i + H100iV2 + H80iV2 and is not really ready for general use. Given it look me maybe 30 minutes to add support to SIV for these I suspect a new CL 3.2 release would have been wise.


Dustin, I gather you have moved on and are now working in Product Management. Good luck in your new role and welcome to Corsair Chris who now has your previous role.









Most of the CL hardware is sitting on my desk and I use it mainly to test SIV. I only ran CL4 so I could update SIV to detect it and not report CL hardware if it is active. I was also hoping that it came with fixed CLCC firmware.











Link to comment
Share on other sites

Why doesn't the graph stay open when the main window is minimized I mean really only way to keep the graph open is with the main window open. Why is corsair so terrible at making software? I think this is the final straw that will send me to nzxt grid+ and hue+ as both are superior products compared to corsairs crap.
Link to comment
Share on other sites

I found it hard to believe how bad CL4 was on my W7 system, so I tried a W10 system and it has many of the same issues.

  1. CL4 wants to reboot the system for no good reason just because it found a H110iGT. As I specified in http://forum.corsair.com/forums/showthread.php?p=822047 this is not needed. While CL was prompting I started up SIV 5.06 which happily reported the H110iGT as you can see.
  2. Testing on W10 x64 RS1 Build 14251 SIV was happily reporting my H110iGT with the initial Device Parameters. I then exited SIV, ran CL4 and it prompted for a reboot. It also zeroed AllowIdleIrpInD3 + DeviceSelectiveSuspended when this is not needed.
  3. If the CPU does not report the Package Temperature the average core temperature for the package should be reported. On a Dual Xeon system there will be two of these.
  4. CL4 incorrectly reports my BL25664FN1608.16FF PC3-12800 DIMMs as PC3-10700.
  5. None of my CSMI RAID or USB attached disks are reported.
  6. The GT 520 Fan PWM % should be reported as it does not report the RPM
  7. My Motherboard Fans are not available on [Configure]
  8. My GTX 680 Fans are not available on [Configure]
  9. The Total % is not available on [Configure]









Link to comment
Share on other sites

Corsair Link won't detect any hardware in my machine, not even motherboard.


I notice a service called CorsairLink4 isn't running. Attempting to run it fails and puts these in the Windows Event Log. CL3 found my stuff. SIV shows Link hardware connected and can control it. SIV is not running when I'm attempting to use CL4. I have tried rebooting many times, as well as reinstalling many times.


Link hardware I have: Corsair H100i, Corsair Link Commander Mini, Corsair AX1200i


Found the culprit: It's conflicting software. I'll be looking at what exact software it was as I stopped like 10 at once. I think it's EVGA Precision X, but haven't been able to confirm yet.

Link to comment
Share on other sites

I have the same problem. My AX1500i is also not detected. It is connected by usb directly.


Also the fans/rpm of my 3 980tis are no longer showing.


I had this problem with my AX760i also... I tried to uninstall v3 and it failed somewhere during it but was able to uninstall it eventually. I installed v4 and it showed nothing so I rebooted and everything was showing. I rebooted again and lost evertyhing again and couldn't get it back. I then noticed that there were two other things installed by the original install dealing with USB dongles and H100 or something... I uninstalled both of them, rebooted and reinstalled 4 and was able to get it to see my PSU again.


As for the fans .. cant help you there .. my MSI fan and MB fans show on the "home" screen but not in the "configure" screen. The only fan that shows in the configure screen is for the AX760i.

Link to comment
Share on other sites

So, is there no way to update the firmware in CL4?


I figured I'd dig out my commander mini out of my closet and give corsair another shot at this. In order to have it functioning I need to update the firmware on the mini and and h100i. In order to update the firmware I need to install CL3.2.5. Now I'm stuck in a reboot loop with the CL detecting a "new" device. And when I fix the reboot loop, updating the firmware crashes with an exception error.


Is someone drinking heavily while coding this software?

Link to comment
Share on other sites

I suspect not and doing as I say in http://forum.corsair.com/forums/showthread.php?t=153706 will address the reboot loop. I recommend 3.2.5742. I suspect USB connecting the H100i may help.


Aye, I'm familiar with your work. I sincerely appreciate what you've been doing all this time.


That's the way I fixed the boot loop, but now I'm stuck with an unhandled exception crash when trying to update the firmware. Back in the closet it all goes. Better luck next time I guess! :evil:

Link to comment
Share on other sites

That's the way I fixed the boot loop, but now I'm stuck with an underhanded exception crash when trying to update the firmware. Back in the close it all goes. Better luck next time I guess! :evil:


Thank you. I try, but Corsair could be rather more helpful. I can't even find the detailed CL4 release notes and wonder if they even exist. Which firmware do you have? I have as below and this is as good as it gets! CL4 does not even seem to have the firmware images:(:. I had to USB connect my H100i rather than C-Link connect it via the CL Mini to update the firmware.




Link to comment
Share on other sites

Yeah, connecting through USB instead of through the Mini allowed me to update the firmware on the H100i.


It just keeps getting better. CL4 detects only 5 out of the 6 corsair pwm fans connected to it and it doesn't allow me to control them in any way.


CL4 detects the H100i connected to the Mini, but it doesn't see any of the fans connected to the H100i.


I'll just continue using AIsutie to control my fans through the swiftech pwm hubs. Much less problematic.

Link to comment
Share on other sites

CL4 detects the H100i connected to the Mini, but it doesn't see any of the fans connected to the H100i.


I'll just continue using AIsutie to control my fans through the swiftech pwm hubs. Much less problematic.


Do any programs? My H100i is via a CLCC and in http://forum.corsair.com/forums/showthread.php?p=833499 you will see all four fans are reported by CL4.


If you choose to run AI Suite that is the ONLY monitoring software you should run as it does not use the Access_SMBUS.HTP.Method and Access_ISABUS.HTP.Method mutexes to interlock access to the hardware sensors. There are many posts about CL and AI Suite issues. As CL is not my software I won't comment on it, but if you run AI Suite and SIV at the same time you are on-your-own as doing this is much the same as playing Russian Roulette.

Link to comment
Share on other sites

Fair enough. I tend to use AIsuite on it's own to control the fans.


This is what I get with CL4 and the latest firmware.




6 Fans connected to the Mini, 4 Fans connected to the H100i. All corsair pwm. AX1500i is detected, but no settings read beyond that. Everyhing is connected through the Mini.


I wonder if I should just RMA the Mini. I ordered one of the first units when they became available. Maybe it's a dud, as it never did work right.

Link to comment
Share on other sites

To all of the Corsair employees that worked on CL4: Great Job! I love the new interface, much cleaner, much easier to work with and cooler to look at. I know ya'll get beat up a lot in these forums, so I just wanted to say thank you for the effort.
Link to comment
Share on other sites

hydros7289.inf should be updated to support the Corsair Link™ USB Dongles so only one driver is needed. Both siusbxp.inf and hydros7289.inf specify the same SIUSBXP service, so having both is silly.


Some users have contacted me asking what the Windows Driver Package - Corsair Components, Inc. (SIUSBXP) USB (10/30/2015 3.6) is and I feel this is a silly name. Given the AXi PSU driver is called Corsair Link USB Dongle (Driver Removal) then a this should be called Corsair Hydro Series 7289 USB Device (Driver Removal) as was the case in CL3.


Please change this.




Link to comment
Share on other sites

Are there any Corsair people looking at these posts?


I have just installed v. and was suprised to see a brand new GUI but quickly dissappointed to see there being no tiles for fan speeds in the configuration tab.


My PWM fans are detected in the system tray quick overview type display as are the GPU fan speeds and the H100i Fan speed but are not visible in the configuration panel. I am not running any other fan management software and the link obviously detects the PWM fans and the others but why no display in the configuration tab?


I appreciate the nicer looking tiles and everything but it sucks that I cannot see the complete cooling system as a nice overview.


Why no obvious changelog? this is a hugely different peice of software and I downloaded in good faith that it was just an update, not a whole different beast.


Will ticket support but would be nice to see some official presence on these forums...


EDIT: At least Corsair allow download of previous versions. I have rolled back to v3.2.5742 until they digitally sign their downloads correctly, release a changelog and fix the configuration issues for non-CPU cooling solutions.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.

  • Create New...