Jump to content
Corsair Community

Corsair Void rgb wireless.


Recommended Posts

Hi peeps,


Wondered if you could help me.

I purchased the Corsair Void wireless today. It wont turn on unless its on charge. CUE indicates different levels of charge constantly. sometimes saying 65% sometimes saying 100%. the LED indicator keeps changing. when its connected to charger it turns on and works fine. as soon as i remove the usb charge lead it switches off.


I dont expect this kind of hassle on a new headset, iv just returned a pair of trittons and replaced them with the void now im getting this issue. First time iv tried corsair headsets, and with this experience im tempted to return them and get another brand.

After reading various threads i couldnt find someone with the same issue. I came across the bootloader issue but when mine is connected to usb charger it turns on and works fine, but the second i disconnect it switches off and wont turn on.





Link to comment
Share on other sites

Have you tried force flashing the firmware again via CUE in normal mode or bootloader mode? Does it help?


If not, request an RMA, attach a picture of your invoice as proof of purchase then PM Corsair Chris with your ticket # and this thread link as it is probably a hardware failure, Corsair usually want them back for analysis to determine the cause.



Corsair Chris



Bootloader steps (Press the volume rocker switch down when connecting the USB cable);


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...