Jump to content
Corsair Community

Weird problem with the shift key on my new Strafe RGB


Recommended Posts

I've just got a Strafe RGB keyboard and I love it, except for a weird problem I'm having with the Shift key. If I press the left Shift key the entire bottom row zxcv... doesn't work. The key presses aren't being registered. The right shift works fine. I've forced an update of the firmware, restarted my computer, unplugged and replugged in the keyboard, tried with and without the usb pass-through being plugged in, even tried remapping left shift to right shift. Nothing works.


The on-screen keyboard shows that the computer is registering the left shift key being pressed and the left shift works with all the other keys on the keyboard, it's only the bottom row that stops working when left shift is pressed.


Weirdly, if I'm quick and press the letter key as I'm releasing the left shift the capital letter gets typed like it should do.


Any ideas on how to solve this/other things to try, or is this an RMA situation?

Link to comment
Share on other sites

  • 2 months later...
I'm having the same exact issue with mine. i even tried your trick of pressing right after releasing the shift key,, and it did the same as yours. the irritating thing is,, i returned the first rgb strafe back for malfunctioning after six months of having it,, and this one,, out of the box,, is doing this!!! I really want this keyboard! but this is getting ridiculous!
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...