Jump to content
Corsair Community

Vengeance 1500 V2 Driver problem


Recommended Posts


I have a Vengeance 1500 V2 Headset since quite a long time and it worked OK apart the too loud sound.

Lately, it has stopped working when I connected it to my USB.

I tried installing it again, but the installation program (version 2.0.37) fails to install the driver.

I also tried with 2.0.16 with same result.

Could you help me ?


I am on Win 7 ultimate 64 bits.

When I look on the properties of the head set, pilot date is 14/08/2014, version


Link to comment
Share on other sites

Thank for your reply.

Yes, the headset is listed in the devices.

I have this error in the properties of the headset :

"Ce périphérique ne peut pas démarrer. (Code 10)"


The problem is that the driver would not install.

I uninstalled it in the properties of the headset, uninstalled the Corsair command panel program and cleaned the register with Ccleaner to make a clean install. With all that done, the install program would still not install the driver.

I really do not understand.


PS : attached file : what I see of the driver


Link to comment
Share on other sites


This morning, as I turned my computer on, the headset was there and working !

After I unplugged it and plugged it again, it was not recognised and not working again !


I turned my computer off, then on : the headset was working.

I never had this behavior before.

Does anyone have an explanation ?

Link to comment
Share on other sites


I tried another USB to the same result.

As the headset is functional when it is plugged on when I turn the compter on, I finally choosed to put the headset permanently on a free USB at the rear of my unit.

I then choose the default device for the sound.

It is not as convenient as plugging and unplugging the headset, but it will do.

Please consider the problem solved.

Thank you for your care.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...