Jump to content
Corsair Community

Headset Corsair Raptor HS40 7.1 USB Gaming Headset / USB not recognized suddently


Recommended Posts



Recently bought this great headset, quite happy about it, used it for about 4 months when suddently one hour ago, it stopped working.


Since I'm using one of the program made by Razer to handle my sound, I thought the problem came from here but I realized that the headset could not be found by it or by the computer.


I tried to restart it, it actually installes some updates and when I tried to see if anything could be fixed, it was still not detected by the computer (and therefore, by the program)


When I tried to unplug & plug it again, Windows gave me an alert stating that the USB could not be recognized by it and that I should unplug it and plug it again. Tried that, didn't worked, same alert came by.


I'm quite startled considering that it happenned suddenly and that the light on the controller of the headset is still working (it's blue at the time) but I can't use any of the controls on it since the computer won't reconignized it.


i tried to plug it in 4 different USB ports without any success. Any suggestions? Should I open a ticket? And since I'm a dumbass, I completly forgot to restart the restauration process since I last disabled it a fez months ago and I don't have any restauration point to see if the updates were the problem...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...