Jump to content
Corsair Community

H100i not detected - at all.


Recommended Posts

Hi there,


Just got the H100i for Christmas and installed it. When attaching the USB cable I noticed that the USB-port in the pump was a bit loose. However, I managed to attach the cable.

Fans are running at ~800 RPM, and the pump must also be running since the CPU is cooled.


Now to the problem:

The H100i is not detected anywhere, not in LINK, not in the device manager, and the registry fix does not work since the files that is to be changed does not exist. I have tried connecting to all the USB headers on my motherboard and I have tried an external connection - still no dice.


Now my question is: is there anything more I can do before starting a RMA?


Thanks for your help.



Link to comment
Share on other sites

Does Windows detect the cooler?

Open Devices and Printers and check if "Corsair Hydro Series 7289 USB Device" or "H100i GTX" is listed. If "H100iGTX is listed rather than the first one, you will probably have to install the drivers via Device Manager or reinstall the LINK software.


Have you tried running SIV (System Information Viewer) created by red-ray? Does it detect your cooler?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...