Jump to content
Corsair Community

Corsair Link showing High Amperage


Recommended Posts

Recently I have been having a problem of my pc shutting down, restarting for a second then shutting down again and restarting, over and over. The only way I can get it to start is by unplugging my PSU and waiting a few minutes.


When I checked the Power Tab in Corsair Link, I saw PCIe 6 A at 56.500. But my system is at idle with only 200 watts usage at the top. If I enable OCP, the whole system shuts down and does that rebooting thing I mentioned above.


Also, the only way for me to remove that reading is again by unplugging my system.


Anyone know a solution to this?


Update: I unplugged the cable for PCIe 6, so there is nothing there. It starts off at 0 bounces around a bit but settles at that 50 plus amp reading.

Link to comment
Share on other sites

Does the computer only shutdown when you run the LINK software and enable OCP?


It also does this, if for example PCIE 6 is stuck at that high reading and I restart or shutdown the computer, it will do that 1 second startup-shutdown-restart loop. Even with OCP disabled. I tried uninstalling Link and unplugging and plugging the PSU again, it did that shutdown loop thing. I thought that the computer would shutdown and not try to restart.


Weird thing is some of the other rails go over 40amps but it doesnt trip the ocp, its only PCIE6.


Is it normal for my gpu to pull that much? Seems kind of high or is Link reporting wrong values? Also, shouldnt that rail always be 0.00 since nothing is plugged to it?



Link to comment
Share on other sites

If it shutdown without LINK installed, it may be the firmware putting out incorrect values as you have also mentioned leaving PCIe 6 unplugged but it still showed readings in the LINK software.


I would contact technical support and see what they say.



I have PMed jonnyguru as well to take a look at this thread, but put in the ticket and see what technical support says.

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...