Jump to content
Corsair Community

K70R w/ Brown switches bricked?


Recommended Posts

I've used a new K70 black with red LED's satisfactorily for about 4 days with a laptop. I did not use USB pass-through at all. I primarily used the reactive lighting mode plugged into a USB 2.0 port on the left side of my laptop since using other lighting modes with the keyboard plugged into any port by my 3.5mm output caused an annoying tone to play from my speakers (a known issue). After unplugging the keyboard to move it to another USB 2.0 port on the other side of my laptop to use the other lighting modes (something I've done before without issue) the keyboard became totally unresponsive. No LED's are lit and no input is detected while plugged into any USB port alone or with other devices plugged in. I have tested all of my ports with all of my other devices (alone and together), including an older Dell keyboard, and they worked fine. While its plugged in, device manager detects a USB input keyboard and the HID Corsair K70 Gaming Keyboard. I have tried uninstalling and letting windows reinstall driver software with reboots. The keyboard also does not respond in BIOS with the polling switch set to BIOS, and firmware updates fail at setting firmware update mode. USB pass-through still works.


I have submitted this info in a support ticket. Is RMA'ing the only option left here?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...