Jump to content
Corsair Community

Scimitar Side Buttons Not Working.


Recommended Posts

Hi Guys,


My Girlfriend got a scimitar today and the side buttons are just not working.


I have installed CUE and gone to Profiles > Remap Key Button the mapped to the number pad. I have also linked it to the WoW Executable.


When i go in game it does not work. I then created a second profile specially for wow, along side the default, and turned on Auto Profile switching and this did not work.


I am getting fed up to be honest i have reinstalled CUE, i have tried unplugging and re plugging it in about 500 different USB ports. :@


Any help would be great

Link to comment
Share on other sites

We have absolutely no idea how but it started working when we changed the remap from Function 13 - 24 to 1-= (not number pad)


we had tried this about 10 times before now it has decided to work.


this is with it on default with no auto profile changing

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...