Jump to content
Corsair Community

CUE software not installing


Recommended Posts

I don't know if anyone will read this but, for Christmas I got the corsair k70 rgb keybaord and the m65 mouse. I plugged them in and tried to download the corsair utility engine and it downloaded fine. Then I tried to run the instalation software and I make it to half way done installing and it freezes my computer so i have to hard shut it down. I have tried everything i can to get it to work i'm lost. Everything else I've tried to download worked perfectly. I spent over 200$ on these peripherals and the whole point of me buying them was to be able to use the 16.8 million colors in the led lights and I can't change them at all. I tried to install the first link on your gaming keyboards page for the k70 and it froze halfway through installing. I also tried to install the first link on your gaming mice downloads page for the m65 and that one froze too. Any help would be appreciated.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...