Jump to content
Corsair Community

Scimitar produces random lag with malfunctioning buttons and LEDs.


Recommended Posts

Hi, fellow forum members and Corsair team!


I just bought my Corsair Scimitar about 2 days ago, and was play testing it.


Basically, I am unsure of how this problem is occurring but seems like some other people also have same issue as I have.


Here's the link to those people who posted either on this forum or .






It looks like the forum post initially created by Tuzark haven't got updates from Henry after his last reply.


On post, there are three people who are having exactly issues that I currently have (including the post creator).


Here's the list of symptoms(?) that I get when the issue happens.


1. the mouse pointer moves really laggy

2. the entire buttons on mouse would stop working completely

3. LED stops working (it lights but it actually stops on the color and the brightness that it was)


My CUE and firmware are up-to-date and even tried to re-install CUE, but it did not fix the problem. Also, I am currently using DPI of 1500, which is not even close to 'less than 6000'.


Like any others, I really like this mouse. I would really love to use it for a long term.


Could anyone please help me out with such issue?








EDIT1: I never tried of recording a video before, but I'll try to upload it when the problem occurs.


EDIT2: I have added some images of my CUE settings for Scimitar

Link to comment
Share on other sites

As Toasted mentioned this is a known issue. Corsair already knows about it and is already working on a fix, I doubt a fix will come out before new year though :p:


Yeap! I realized that there are already bunch of threads talking about this issue right after I wrote this thread lel...............


I tried to delete this thread but couldn't find a "Delete" button hehe......

Link to comment
Share on other sites

  • 11 months later...
I just bought this brand new Scimitar a few days ago and was very excited about it, but 2 times now, LED gets locked on one color, buttons stop responding, and it's laggy mouse speed until I reboot the computer. Hated Razer software, it was intrusive and the old naga couldn't do anything special anyway, but IT WORKED for about 4 years. The Scimitar couldn't even function without using the god awful CUE software and setting up macro side buttons. I didn't need macros, I simply wanted them to be the normal 1-12 buttons like they were on the razer naga. After I jumped into a moba game and realized none of the side buttons actually worked like 1-12, it was annoying, especially after only playing mobas with side mouse buttons for years and never with keyboard keys. This whole issue if the mouse stops working and needs unplugged, is all over the forums and other sites from almost a year ago. Why is this still a problem? Corsair should probably outsource their programming and software team by now to a group of people that can actually code and fix issues.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...