Jump to content
Corsair Community

Corsair Void 20+ Seconds to connect on Startup Everytime?

Recommended Posts

This is one of the most aggravating things to me that may seem small/unimportant but why does this happen? My issue with the Corsair Void RGB Yellowjacket is that when my computer is on, whether it's from a fresh boot, or it's been on for 2 hours and I go to turn on my headset it takes 20-30 seconds for the headset to be 'received' or 'paired' with the computer every single time.


Now I've tried re-pairing it, doesn't work, I've tried re-installing CUE, doesn't work, I've even had a Windows 7 re-installation since I bought this headset in the fall and the exact same problem persists making it a hardware issue. Now in my room there is nothing wireless at all except for my headset. My keyboard is hardwired, my mouse, my webcam, my speakers and the router/modem is over 70 feet away, I know this because I had to get a 100ft ethernet cable. So there is nothing running on the 2.4Ghz band in my room at all, and my dongle is about a whole 2 feet away from me as it sits on my desk right in front of my tower on the edge of the desk and I can outstretch my arm and touch it so it's not a signal issue either.


So troubleshooting out of the way, can we get a tally as to see if this a normal thing for other users or if I have the odd duck out? I've googled/forum searched this and found nothing. I'm coming from the Logitech G930, and while I enjoy this headset miles more, this one consistent thing, as small as it is, is really driving my OCD up the wall. When I go to watch a Youtube video and sit there for another 20-30s staring at my screen waiting to hear the connection chirp in my ear as the headset just constantly flails through the color spectrum while the infomic blinks red repeatedly trying to connect.

Link to comment
Share on other sites

My headset does the same thing .. only when headset has been off for a long time..


Doesn't bother me though.. then i don't have to see that lamp thing blinking all night on the usb dongle either! :D:


Edit: Mine started doing it on the latest firmware.. you could try and see if you could get a hold of the last version of the firmware :):

Edited by IstBarP
Link to comment
Share on other sites

I don't have the Yellow Jacket, but my wireless Void does do this. Sometimes, it connects nearly instantly. Sometimes, it takes upwards of 10, 20, 30 seconds to connect like you described. It does it even if the headset is plugged in to charge. It sometimes does it even if I turn it off, then immediately turn it back on. It also does it sometimes if the headset is literally sitting right next to the dongle on top of my computer when I turn it on.


It's a minor inconvenience, and a minor frustration, but I never had this issue with my Vengeance 2000, not even once.

Link to comment
Share on other sites

  • 5 years later...
I have the Corsair Void Pro Wireless and I am having this issue. Nothing I've tried can fix it, or even reduce the time it takes to connect. Seems that the dongle checks in 30 second intervals if the headset is on, really frustrating that you can't change this interval to say, 1 second
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...