Jump to content
Corsair Community

Can't Install M65 Vengeance Driver


Recommended Posts

So this has obviously been an issue for awhile (according to searches) and while I used to have this working, I did a fresh Win7 64Bit install on my machine and then tried to run the M65 (from Corsair) and it keeps telling me that it can't find the mouse (which is working).


I have tried all of my 2.0 and 3.0 USB ports, uninstalling the Device Mgr/Mice and Other/HID-compliant mouse that show up (and re-show up) when I remove the mouse and plug it back in. I tried also installing the CUE and it won't detect the mouse or the kybd (although the Corsair K70 Gaming kybd does show up in the device mgr).


With regards to the mouse not being detected, has there been anything new and obvious to fix this (or do I have to keep trying stuff from the old threads). I wish I knew what I did the last time I got this working - is there any place to get the drivers for the mouse that are not bundled in with all of the main software install (so perhaps I can install them directly and not go through the Windows installer package that stops when it can't detect the mouse)?




Link to comment
Share on other sites

I AM AN IDIOT! After digging through all of my archive files I realized I have an M60 and not an M65 (which is why the updated driver install did not work). I thought I had the 65 based on the pictures (the label has come off a long time ago). Problem fixed!
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...