Jump to content
Corsair Community

Keypress long delay after login


Recommended Posts

Hi I have the following problem with m K95 Keyboard


When I boot the computer I get my login screen, when I type my username and password the keyboard is working normally.


However, when I login and my desktop is loaded the keyboard stops responding properly (only allowing for 1 keypress every 10 seconds). This continues until the CUE software is loaded. When the CUE software is loaded (when the lights turn to my default color scheme) the keyboard will react normally again.


I have tried to uninstall and reinstall CUE. I also tried setting a different polling rate (the button at the back of the keyboard), this does not solve my problem.


I’m currently running the following versions:


CUE: 1.13.36

Firmware: 1.33

Bootloader: 0.11


Thank you for your time and effort!



Link to comment
Share on other sites

Do you have the latest BIOS, chipset drivers and Windows update?

Have you tried a different USB port?


Hi, thank you for your reply,



I have tried different USB3 slots (only one the cable with the keyboard icon plugged in).


I updated my windows


I updated my ChipsetDrivers + USB3 drivers


I updated my BIOS (latest version is in 2013 though)


Also, when i login the keyboard will react normally for about 1 to 3 seconds when the slow key detection problem starts.


When the problem starts, I can hear windows make a sound that a device is connected/disconnected. After arround 30 seconds windows makes the same sound again. A few seconds after the 2nd time windows makes this sound, the keyboard works normally again. It seems like windows uses different drivers when logging in, disabling them after login and taking a lot of time enabling the correct drivers for my keyboard?






After a few reboots, windows stop making the connected/disconnected sounds. The problem with my keyboard is still there, it seems the drivers load a little bit faster now though.

Before posting my first post I deleted all HID keyboard Device entries in the Device Manage to ensure no drivers from my previous keyboard exists.


When I look at the Device Manager again I can see 6 entries for "HID keyboard device" which sounds weird to me since only 1 keyboard is connected.



Updated BIOS

Edited by Maniaknl
Link to comment
Share on other sites

  • 4 years later...
I have problem with Corsair K95 RGB keyboard on Intel P67 based motherboard and Asus Gene VII Z97. Both motherboards (no matter what USB port I try) hang on UEFI boot screen right after POST (from 1 to 2 minutes). I cannot enter UEFI on P67, while I can on Z97, Z97 is having wakeup issues. Total mess.
Link to comment
Share on other sites

  • Create New...