Jump to content
Corsair Community

Possible TWINX1024-3200C2PT Problem?


Recommended Posts

I have two sets of TWINX1024-3200C2PT modules (total 2GB) running in an Intel D875PBZ motherboard with a P4 3GHz CPU 800MHz FSB. I assembled the system about a year ago, and everything was fine until a week ago. No recent configuration changes. I started getting flakey behavior while video editing (application crashes, incorrect cursors, audio artifacts, sync problems, etc.). Restarting the system would clear the problem for a few minutes or sometimes a couple of hours.


I ran Memtest-86, and got anywhere from 10 to 46 errors in various places within a hour of starting the tests (sometimes as soon as 12 minutes into testing, with failures in test #5). I checked the cooling (all fans working, Intel's utility reports temps within good limits even at 100% CPU usage), and power supply (ok, but upgraded the power supply from 400W to 500W, just in case). Memtest-86 still fails. The single-bit errors occur at different addresses each time, and the failing bit positions change as well. I reseated the memory modules and AGP card, same result. I swapped around the memory modules (but kept the original pairs together), same result.


I have not changed any of the frequencies, voltages, or timing from the defaults. I have never overclocked the system. I have no other systems that accept this type of memory, in which to test the modules.


I'm working on a project that I need to complete soon, and so need to stabalize this machine quickly. Even if there's a way to "dail down" some setting to make the memory more stable, I'd be willing to accept slower performance until I complete the project.


Could you point me to any info on what I might be able to do to (1) narrow down whether I indeed have one or more bad memory modules, (2) temporarily stabalize the system to allow me to complete my project, (3) resolve the problem long-term (replace existing modules with the same, or use ECC instead, etc.)?


Thanks very much for your response.

Link to comment
Share on other sites

  • Corsair Employees

On our TwinX1024-3200C2; please set the following setting, but before making the necessary changes please make sure that you have the latest BIOS installed on your MB.

SDRAM Frequency - 400


SDRAM tRASmin - 6




DDR Voltage 2.7 V

All other settings should be set to default settings!

Then please test them one at a time with http://www.memtest.org and let’s make sure it's not some other issue! I would run the test for at least 2-3 passes to be sure!

Link to comment
Share on other sites

Thanks very much for your prompt reply. I can change all the settings you suggest, except for one. I can't seem to find any control over DDR Voltage. I looked through all the BIOS screens I could find. I am running the latest version of BIOS for this motherboard, version P33, which according to Intel is dated 12/1/04. Is there some secret place where the DDR voltage can be set, or do I have a blind spot? If this BIOS doesn't let you change the voltage, is it safe to run with the other changes and not change the voltage?


Thanks again.

Link to comment
Share on other sites

  • Corsair Employees
If you have the latest revision of this D875PBZ MB then you should have the voltage settings, but if you have an older one then you may not have it on your BIOS setup. Yes the settings that I gave you will be the optimal settings for your memory modules regardless if you have the voltage settings on it or not.
Link to comment
Share on other sites

The motherboard itself is over a year old, but the BIOS is the latest and greatest, according to the Intel website. The printed manual that came with the motherboard indicated that the memory must be 2.5V. I took one more pass at all the options, and found no control over DDR voltage.


So, assuming that the other new settings test out OK, I should just keep these new settings going forward. Great.


What's odd to me is that I've been running with all default settings for a year, but just encountered problems a week ago. Perhaps I was getting errors with the old settings, but just now the application and/or data started using that memory, generating the odd behavior. Or maybe that cosmic ray collector I installed on the front lawn has had an effect.


Anyway, thanks very much for your prompt assistance. I'll post my results after running the tests.

Link to comment
Share on other sites

OK, here are the test results. Running with CPC Override disabled, 2-3-3-6, and everything else at default, and using Memtest86+ v1.4, I tested each 512MB module individually in the DIMM 0 Channel A slot (512MB total system memory). Each one passed all the tests after 3-4 passes each.


Next, I tested the first matched pair in DIMM 0 Channel A and B (1GB total system memory). That pair passed all the tests after 3 passes. Next, I removed those modules and installed the second matched pair in DIMM 0 Channel A and B (1GB total). The test of these modules failed in the following way:


Test 5, Pass 2, Address 000306d3568, Error Bit 00000800

Test 5, Pass 2, Address 000316d3548, Error Bit 00000800

Test 5, Pass 3, Address 00036bdada8, Error Bit 00000800

Test 5, Pass 3, Address 00037bdad88, Error Bit 00000800


So, individually, the modules passed the tests. The first pair also passed. But the second pair failed as above.


I'm not sure what this says...that the modules are OK individually, but one of the pairs (the second pair tested) doesn't work well together in dual-channel mode? I'm not quite sure what I should test next. Recommendations?


I did note that throughout these tests, the program reports "RAM: 199MHz (DDR398)". I assume this is nothing to worry about, but mentioned it just in case.


Thanks for your continuing assistance.

Link to comment
Share on other sites

While typing the previous reply, the test of the second pair was still running, and got the following failures on pass 4:


Test 5, Pass 4, Address 000102d34e8, Error Bit 00000800

Test 5, Pass 4, Address 000112d34c8, Error Bit 00000800

Test 5, Pass 4, Address 00034bd31e8, Error Bit 00000800

Test 5, Pass 4, Address 00035bd31c8, Error Bit 00000800


Don't know if this additional info helps, but thought I'd report it.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...