Jump to content
Corsair Community

Windows 10 TH2+RS1 - Fix for CL 3.2.5742 discovered new devices reboot needed popup


red-ray

Recommended Posts

Red-Ray I thank you so very much. That stupid loop was driving me nuts this morning. I allowed it to do the reboot as it asked for and continued to loop. Found your message, went into Regedit found the spot you were talking about and zapped it. Rebooted nice and clean, thank you again.

 

Iceman

Link to comment
Share on other sites

  • 3 months later...
  • Replies 106
  • Created
  • Last Reply
  • 11 months later...
Think you may need to specify that this does not work for windows 10 x64

 

Thank you for the report, but which Windows 10 did you have the issue with? There are 4 different ones and then all the insider builds. Can you post some more details please? What device?

 

I know it worked for the H100i of greyze a couple of days ago.

 

Did everything on your list and it worked, i'm now on the latest firmware. Thanks very much :)

 

Think you may need to specify it has a different address on windows 10 x64, yet it seems fine anyway.

 

Which registry key did you use?

Link to comment
Share on other sites

  • 2 months later...
I have seen many threads about issues with endless reboot popups on W10 TH2 + RS1 and decided to try and figure out what was really needed. The bottom line seems to be that you just need to delete SelectiveSuspendEnabled for ALL the Corsair Integrated USB Bridges. If you check HKLM\System\CurrentControlSet\Enum\USB\VID_1B1C&PID_0C04\<different on every system>\Device Parameters with REGEDIT you will typically see:

 

attachment.php?attachmentid=23410&stc=1&d=1448445443

 

Note that SelectiveSuspendEnabled is REG_BINARY. Right/Click on it and select Delete. Having done this run CL, refresh the REGEDIT panel and it will be:

 

attachment.php?attachmentid=23411&stc=1&d=1448445451

 

Note that SelectiveSuspendEnabled is now back after being deleted, is now a REG_DWORD and the others have been set to zero. Repeat this for ALL the Corsair Integrated USB Bridges and Corsair Link PMBus Bridges (note PID is 0C02).

 

All I did was cancel the new hardware detected panel and all seems to be OK.

 

To me it seems that CL is trying to do the EnhancedPowerManagementEnabled kluge and the code is far from ideal. I suspect that it's doing a RegSetValueEx() to set SelectiveSuspendEnabled to zero which is failing as it's a one byte REG_BINARY rather than a REG_DWORD.

 

I further suspect the CL code is incorrect as all that I expect is needed is to set EnhancedPowerManagementEnabled to zero and CL should not be changing any of the other Device Parameters at all. Changing a standard Microsoft parameter from REG_BINARY to a REG_DWORD is at best poor and I feel a very bad idea which is likely to cause undesirable side effects.

 

After more checking on W10 TH1 SelectiveSuspendEnabled is a REG_DWORD and on TH2 + RS1 it's a one byte REG_BINARY.

 

I reported this issue to Corsair on 24-Sep-2015 so it could have been fixed before CL 3.2.5742 was released. Corsair really do need to get their act together.

 

Only EnhancedPowerManagementEnabled needs to be set to zero and none of the other Device Parameters should be changed/set to zero though there are many misleading posts that say they should. I also suspect CL 3.2.5742 is setting things to zero when it should not be and this should be corrected. CL needing to reboot the system is very silly as all it needs to do is restart the USB device which takes two lines of code.

 

i cant find that folder. my win 10 pro 64 bit asus x370 hero 6

Link to comment
Share on other sites

i cant find that folder. my win 10 pro 64 bit asus x370 hero 6

 

Looking at your other posts you have an Asetek H100iV2 and this change only applicable to the CoolIT H100i or other CoolIT devices..

 

Further you are using CL4 and it's only needed for CL 3.2.5742.

 

Looking at http://forum.corsair.com/forums/showthread.php?p=914257 your issue is that Windows is not detecting the Asetek H100iV2 at all.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...