Jump to content
Corsair Community

Windows 10 TH2+RS1 - Fix for CL 3.2.5742 discovered new devices reboot needed popup


red-ray

Recommended Posts

I could not agree more, red-ray, and thank you for your efforts, your fix worked for me. I suspect Corsair may be ambivalent about highlighting a fix to a problem they should have already corrected themselves. Particularly as your fix involves manual registry editing, as they might be afraid of the liability of users who make an error somehow and mess up their registry in the process.

 

I do think a Corsair support person should post some sort of response to the issue, i.e., recognition of the problem, what they currently recommend, and a projected time frame for an update to correct it.

Link to comment
Share on other sites

  • Replies 106
  • Created
  • Last Reply

Hey, I hope you guys can still offer some support here.

I updated my Win10 to 1511 a few days ago and just started up Link.

It worked okay-ish except that notification about new devices and that my H110iGT fan speeds were not displayed. I restarted my system, but that did not help.

I then realized I only had the 2nd latest Link verions installed and thus uninstalled the old version, restarted and installed the latest Link version.

Now my H110iGT is not even shown in link. I uninstalled two driver thingies from Corsair (an usb dongle thing and a hydro series driver) and then uninstalled Link again, restarted and reinstalled from scratch. All the programs reappeared in my list, and I'm at the same point as before - no Pump shown in link.

I checked the registry (done so at the beginning too) - no binary variables, all as it should be.

Then I looked into my device manager and realized I had an error there:

I've got an USB device called "Unbekanntes USB-Gerät (Fehler beim Anfordern einer Gerätebeschreibung)" which is german and roughly translates to "Unknown USB-Device (Error when requesting the Device description)".

I can't seem to get a hardware ID rom device manager either.

The only info I can find is in the error log: The PIDs 0002 and 0917 are listed.

I also downloaded SIV, but I don't exactly know what to do with it. I entered Link devices and I get shown the registry entry for the pump and the info that it's probably a ghost device.

 

I hope I supplied enogh info about my issue and that you can help me.

 

Oh and by the way, Link worked fine before the large update.

 

Thank you for helping,

- Shad0w

Link to comment
Share on other sites

Posting the SIV [uSB Bus] and [Link Status] panel screen shots may help me figure out what has happened.

 

In Device Manager uninstall the H110iGT, do find new hardware and specify what happens. Posting a Device manager screen shot may provide some insight.

 

Ideally attach .PNG files to your post.

Link to comment
Share on other sites

I guess you're right with that...

Still, I'm ok with it as it is right now, and i won't change a thing until I think it's time for an update or it starts being buggy again.

Never change a running system :D

 

I actually only tried to start link again because I thought one of my fans was vibrating and turning it to 100% for some secs normally fixe that. I couldn't do that without link though. Now I did that after "repairing" link and the noise didn't go away.

I just realized it was my goddamn desk lamp all the time!

 

Version used: 3.2.5695 (latest would be 3.2.5742)

Link to comment
Share on other sites

  • 2 weeks later...

Thank you red-ray for this fix. I made an account here just to tell you that!

 

Corsair should pay you for making their software work. I was ready to return this cooler and order a NZXT but now I think I'll keep it.

 

Edit: FWIW, after applying this fix, filezilla server wouldn't connect. Uninstall>Restart>Install fixed it.

Link to comment
Share on other sites

Thanks so much Ray!

 

I did the reg-edit and siv64x to get it to display my fans and pump in CL.

 

My fans and pump would not load. I got that working now but the warning message keeps coming up. I read somewhere that you disabled that but I can't find it anywhere.

 

How do I do this?

 

http://f.cl.ly/items/2Y2s3R3D2K003y3W1W0p/CorsairLink.jpg

Link to comment
Share on other sites

Here is the info in Siv64.

 

Looking at [Link Devices] most of the Device Parameters seem to be missing. Did you delete them? There should be as below.

attachment.php?attachmentid=22619&stc=1&d=1439790622

 

To get them back press [Restart] and then using Device Manager uninstall the Corsair Integrated USB Bridges from the HID section and then do scan for hardware.

 

You also seem to have a ghost H80i. See https://support.microsoft.com/en-us/kb/315539 for how to delete it (doing this on XP and later is much the same)

Link to comment
Share on other sites

I deleted them because they weren't moving, they re appeared in CL again after I pressed cancel to the message. I did unplug the USB header as I did some cable management cleaning since I got a new Fury X which needed a new case which introduced this issue. I did have more listed there yesterday.
Link to comment
Share on other sites

Thanks so much Ray, it's now fixed.

 

http://f.cl.ly/items/1I3n0z2J393E3k2n0J1D/corsair_link_fixed.jpg

 

I think I didn't start and close CL after deleting the registry entry as last time I had a few with value of one, this time they are all zeros. The new devices warning no longer comes up.

 

Big Thanks for your awesome work!

Link to comment
Share on other sites

Red-Ray, you seem to be the most helpful person I've found for these types of issues, was wondering if you might be able to help me troubleshoot. I've built a new system, and am having 2 red blinking icons in CL, the H100iGTX Cooler Fan and the GeForce GTX980 Ti Fan. I've tried a number of things, but now seem to have tied myself in knots. My registry doesn't seem to have the correct parameters any longer to modify per the thread instructions, and I can't seem to get them back. My fans are all spinning, but the reports I get from CL and SIV seem to indicate a few issues: 1) only 1 fan attached to my H100i GTX, and it doesn't spin (though in reality I'm watching both my radiator fans spin right now). 2) For some reason, CL doesn't seem to think my video card fan is working, though it seems to spin just fine. 3) In the Link Limits window, I don't have a value entered for my PSU, the AX860i.

 

Any chance you can point me in the right direction to get everything on track sir? Your help would be invaluable!

1010315742_Screenshot(4).thumb.png.4e3b790c06cdacf6806283bce43de447.png

981895360_Screenshot(2).thumb.png.c399083f8e1ccb66350316e9c92cb269.png

736331571_Screenshot(3).thumb.png.cedb8f2463e40c1e6fbcdd844460606d.png

1086561261_Screenshot(5).thumb.png.6adcecfe5b8844e597493e9210cbc125.png

Link to comment
Share on other sites

The H100iGTX isn't a HID device so no registry changes are needed.

 

The H100iGTX only has one fan controller and only reports the speed of one of the fans. Both should run at the same speed, but if the one that is not reported stops there is no way to know this. See http://forum.corsair.com/forums/showthread.php?p=796027.

 

SIV only reports AXi PSUs that are C-Link connected. I would like to add USB support, but as yet have not figured out the protocol and as usual Corsair have declined to help. All of Tamas (AIDA64), Martin (HWiNFO) and I keep trying to get this working.

 

To sensibly comment of the flashing fans I need you to post the SIV [Link Status] + [GPU Info] screen shots.

Link to comment
Share on other sites

Red-Ray, thanks for such a fast response! As requested sir:

 

Looking at [GPU Info] the requested GPU fan speed is PWM 0% so the fan should not be spinning which is the situation. I feel there is a bug in CL and it should not flash the GPU 0 RPM red when the PWM is 0%. I feel you should report this bug via https://corsair.secure.force.com/home/home.jsp. I recall seeing others posting about this issue.

 

The Cooler Fan being 0 RPM is a hardware issue as both the pump speed and fan speed are returned in the same message it can't be a software issue. It could be a fault with one of the fan tachometers, so try swapping the two fans. If that fixes it then RMA the faulty fan and if not I suspect you will need to RMA the H100iGTX.

 

BTW is you press Alt/PrntScn that will copy the current panel rather than the whole screen.

Link to comment
Share on other sites

So I did all as followed, except you say to delete all the integrated USB bridges and such. However, the only one I'm aware of is the one under _0C04. I deleted the "SelectiveSuspendEnabled" and the option to reboot is finally gone. However, fans and pumps always blink red, and the numbers always switch from accurate to 0, or below 100 for the fans and temp probes I have. Also, after a few minutes, all my fans will restart.

 

I never had the issue when I went from W7 to W10 via the Microsoft upgrade download. The issue occurred when I did a fresh install from an ISO via Microsoft.

Link to comment
Share on other sites

do you know what the small number in the circle at the upper right for each icon in CL means?

 

From the image below the Small Circle seems to be the Group Number :idea:.

 

I hovered the mouse over it expecting a ToolTip, but there is not so I feel Corsair should fix this :asskick:.

 

attachment.php?attachmentid=23846&stc=1&d=1452085718

1488090595_SmallCircleseemstobetheGroupNumber.thumb.png.383f418dee08556a1888ba1d79c29e33.png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...