Jump to content
Corsair Community

Issue regarding Macros and Keystrokes

Recommended Posts



I recently purchased one of the new limited-run K95 RGB keyboards with blue switches and it arrived today. I've had some time to play around with it and am currently very pleased with it, but I'm having an issue that I can't seem to find a solution to.


I think I've more or less figured out how to use the CUE software, but it seems that trying to assign Macro and Keystroke actions to keys isn't working at all. At first I thought the issue was that my G keys weren't working, but I noticed that they were responding to Type Lighting Events and when I tried assigning macros to the standard keys, none of them would work either.


I tried doing some googling to see if I could find a solution to the issue and came across this thread: http://forum.corsair.com/v3/showthread.php?t=138944

in which it seems that the poster is/was having the same issue I am.

After seeing that assigning Text actions to his keys was working for him, I tried the same and Text actions work fine for me as well, even on the G keys.


So in other words, the issue is this: my keys seem to work just fine functionally but for whatever reason will not execute Macros or Keystrokes when pressed, but they WILL execute Text actions and respond to Type Lighting.


Just to ensure that the problem was specifically with Macros and Keystrokes, I tried assigning them to both a G key and the End key, then opened up a text editor to see their effects. The G key did nothing when pressed, and the End key seemed to have no effect whatsoever (not even its default End behavior) but when I reassigned the action to a Text action, both the G key AND the End key responded as intended and typed out the test message that I assigned to them. When I removed the assigned action, the End key went back to its default behavior and functioned as the End key normally should.


Because Text actions work fine, I can conclude that the actual keys are working as intended and the fact that the End key stopped working altogether when I assigned a Macro/Keystroke to it shows that either the keyboard or the software is preventing me from executing Macros/Keystrokes specifically.

One of the main functions I bought this keyboard for was its ability to use macros, so it's pretty important that I get this working.


Can anyone help me out?


For reference, my OS is Windows 7 Ultimate 64-bit.

Here's a screenshot of my device manager window if it will help. I'm unsure if my drivers are set up correctly or if I'm supposed to have this many generic input devices.


My previous keyboard was a Logitech G15. Should I uninstall the driver that appears in my device manager?

Link to comment
Share on other sites

Okay, I went down the list and uninstalled all of the devices there until I ended up uninstalling my mouse itself and couldn't get rid of any more.

After rebooting the computer, I tried again and macros still aren't working (but Text is).


I'm getting a different error when I try to use macros now:

[2015-05-07T16:58:44]: Buffer write failed, 1. request timed out

[2015-05-07T16:58:44]: Buffer write failed, 1.Execution result = 0, result = 0, platform error code = 995.


Here's what my device manager currently looks like.


The Logitech virtual keyboard re-installed itself after a reboot so I uninstalled it again. I actually do use a Logitech mouse though so I needed to keep that one installed. There seems to be one less HID keyboard device installed but still a bunch of other stuff.

Link to comment
Share on other sites

From the errors it seems that the Logitech software is overriding the Corsair one.

The one less HID device is most likely the Corsair Virtual Mouse


Try Uninstalling the Logitech and Corsair software. Reinstall CUE first then reinstall LGS

Might also want to use CCleaner to clean the reg before reinstalling the Free version should work fine.

Link to comment
Share on other sites

Okay, with zheren159's help, I fixed the issue!


I uninstalled both LGS and CUE, then unplugged both my mouse and keyboard and plugged in a generic mouse and uninstalled all of the USB devices that showed up in the device manager.

I then ran ccleaner on the registry and rebooted the computer.

I unplugged my ethernet cable so nothing would connect to Windows update, then reinstalled CUE (I still had the setup exe saved) and plugged in the K95. Unlike before, a "Corsair composite virtual input device" now shows up in my device manager and Macros and Keystrokes now work as intended.

I was going to reinstall LGS, but I don't use macros on my mouse and I no longer have the G15 hooked up to this computer so I didn't really see the point since I can still adjust my mouse's DPI through the hardware buttons and the button settings that I had on it were saved in device memory so it works exactly as before.

In other words, the problem is now solved.


Thanks for your help! :)


To Corsair James, my mouse is a Logitech G500.



edit- Before I finish with this topic, I have a question for anyone who can answer it.

What determines the keyboard's lighting behavior when the computer is locked? I've had three different scenarios happen now with the first being the default red with white WASD, then after I rebooted I was getting no lights at all, and now that I've reinstalled I was getting the profile that was previously saved to device memory, which I've since updated (but is still being loaded on lock.)

Do I have to reboot the computer every time I want to change lock behavior?

I kind of liked the lights turning off when the computer was locked but if I could change that from time to time that would be cool too.

Link to comment
Share on other sites

  • Corsair Employees
Viper, the lights that are displayed when Windows is locked is whatever you saved to the onboard memory for background color. Therefore, if you want the keyboard to be blacked out, simply make a new default profile and save it to the onboard memory.
Link to comment
Share on other sites

  • 1 month later...





So basicly I had previously installed my gaming mouse with macros also, so I did the same steps as you but I didnt unplug the ethernet cable (lol) and then I installed my gaming again and my keyboard macros works perfectly and the mouse ones too.



So nothing else to say a really big Thank you bro! I was about to freaked out coz I couldnt find a solution for this. :)

Link to comment
Share on other sites

  • 2 years later...

Anybody who can please help me out here?


I have the same problem. But the macros that DO work are plain text and programs.


I tried the steps that Vipershark provided, but they didn't work for me.


I did get "Corsair composite virtual input device" to show up in Device Manager, but right after I click "finish" in the installation/repair wizard it disconnects.


EDIT: It's fixed! Keyboard required new firmware.


"I've attached a firmware file to this ticket and here are the instructions for a manual flash:

1 - Please completely exit out of the Corsair Utility Engine Software

2 - Disconnect the unit entirely from your system

3 - Using a paperclip, thumb tack, or thin needle, please hold down on the reset button (located next to the polling rate switch, under the left leg of keyboard, or under the top weight storage for mouse)

4 - As it is pressed down, please connect the unit to a USB 3.0 port on your system (please ensure the connector labeled with the keyboard icon is connected only)

5 - A file explorer pop-up (check file explorer if it doesn't) will be displayed showing drive name as CRP_DISABLED

6 - Please ensure you first delete the firmware.bin file that is on the CRP_DISABLED drive. Transfer the ISP bin file that is attached to this ticket over to the CRP_DISABLED drive.

7 - Insert the unit as you normally would to have the keyboard initialize."


Firmware file: "K95RGB_ISP_V205.bin"


EDIT 2: Problem returned. Yay.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...