Jump to content
Corsair Community

Keys pressing on there own.


Recommended Posts

I came home today from work to find that my computer had BSOD and restarted. My keyboard was constantly pressing down certain keys over and over and the LEDs are not displaying the correct color that's set. not sure if its software problem or hardware. I'm hoping software haha I hear these boards are hard to RMA cause of stock issues.


I can get it to stop by switching the LED's off but when I turn it back on even to the default profile it starts back up again. weirdly depending on the color thats set it presses the keys at a different pace(all pretty fast paces though, red is the worst).


These are the keys is pressing(yellow/orange means it was pressed)



Troubleshooting steps I've taken so far in order that I did them...

  1. restarted computer of course
  2. unplugged and plugged into different slots including USB 2.0 and USB 3.0
  3. tried just using the usb that has the keyboard icon on it in the USB 3.0 slot(which is how I usually use the keyboard)
  4. Updated to CUE 1.3.91
  5. backdated firmware to 1.13 still happened so updated through CUE back to 1.15
  6. uninstalled CUE and deleted corsair folder in roaming %appdata%
  7. reinstalled CUE 1.3.91


it's probably worth saying that its mashing these keys before windows is even booted. I know this because I have a windows 7 install disc in my CD drive and it pops up when I start to press any key to boot from CD. the keyboard mashing its keys triggers that.


Is there a way to reset the keyboard, theirs that little hole next to the bios switch haven't stuck anything in it yet but wasn't able to find if that's a reset hole or not.


phones battery is dead right now but i'll take a picture of the keyboard lighting as an example of the LED being off color later.

EDIT: adding image of LED issues color is set to everything being red




TLDR; Keyboard mashing down keys constantly when LED's are on

Edited by Elumis
Link to comment
Share on other sites

The scroll lock indicator flashing indicates the keyboard in in BIOS mode. Move the switch back to a number. Does the issue start appearing or has it disappeared?


BIOS mode basically turns off all the "Advanced" features of the keyboard such as N-key rollover. It is usually used when you need to access the BIOS during startup.

  • Confused 1
Link to comment
Share on other sites

  • 1 year later...
  • 9 months later...

Have exactly the same problem with my K70 keyboard except the faulty buttons are different. Keyboard has been okay for 1 year and the problem now just started. Below you can see the things I have tetsted. My conclusion of testing looks looks like it might be some sort electronics driver of the LEDS in the keyboard malfunctioning. It definately is not hardware, firmware or CUE related.


- Problem exists with CUE versions 2.16.87 and 1.16.42 (rolled back)

- Problem exists with Firmware 2.05 and then rolledback to firmware 1.29 and the same problem.

- Keyboard works okay with the BIOS switch on the keyboard selected. The keyboard hardware is not the problem.

- Keyboard seems to work fine when lighting level is set at 33%. Issue seems to only occur at 66% and 100% light intensities.

- Setting profile back to default did not fix the problem.

- Will test on a different computer and if the problem exists will send in for a replacemente / fix.



***UPDATE & FIX***

Try a soft reset. Seems to have fixed my issue so far:

- Unplug the keyboard

- With the keyboard unplugged, hold down the ESC key.

- While holding down the ESC key, plug the keyboard back into the computer.

- After about 5 seconds, release the ESC key.

- If done correctly, your keyboard's lighting will flash.

- Re-upload the profile to the keyboard.

Edited by obvious_sarcasm
Link to comment
Share on other sites

  • 1 year later...
i have had the same problem only problem was i was working on my pc at the time and all my work is lost Corsair doesn't seam to be fixing this problem .... i tried all the fixes but nothing worked for me .... the only way i have found to fix the problem permanently is to never buy a corsair keyboard again and the one i have will soon be in the bin Edited by lionfires
Link to comment
Share on other sites

  • 5 months later...
i'm having the same problem, and i tried what you said but its not working,do you have any other advise? i would like to give it a try


Start a new thread. This one is nearly 5 years old and surely you don't have the same hardware and certainly not the software from back then. Detail your issue. Don't just say it is the same as someone else. Do include the relevant hardware, like your keyboard and what version of the software you are currently using.

Link to comment
Share on other sites

  • Create New...