Jump to content
Corsair Community

Corsair F120 not detected in BIOS


Recommended Posts

I had been running the F120 as my boot drive for some time.


Recently I upgraded my Motherboard, Chip, RAM and Video card. The Drive became problematic - intermittent visibility in the boot up, BIOS etc.


I messed with all sorts of settings in the BIOS, changed cables, changed the port the drive was plugged into, tried the SSD toolbox, but ended up hitting F11 every time I booted to see if the drive was being located.


Well, the other day I started Windows only to get the BSOD. I tried the repair options, the refresh options, the reinstall options, but eventually got nothing back.


I have taken the drive out after trying to locate it in the BIOS and plugged it into a SATA dock attached to my laptop. Lo and behold, there it is. With a fresh version of Windows on it and all my old data gone into the ether.


I see that I am not the only one t have this problem, and of course, I am now about six months out of warranty (as usual).


No firmware updates seem to exist for this drive.


How do I get this sorted?


I am considering buying another SSD (not Corsair, thanks) and starting from scratch.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...