Jump to content
Corsair Community

Vengeance 2100 issue with dongle?


Castodius

Recommended Posts

Hi all,

Looking for advice/help with my vengeance 2100 headset.

The headset has worked fine up until this morning, the problem seems to be the usb dongle I think.... Basically once the pc is turned on the dongle is constantly on (blue led) I've tried switching it on and off using the headset as normal to no avail. I have tried various usb ports and reset on the dongle. It never returns to flashing.

Does anyone know what this could be or if it is Infact a dongle issue? I have opened a ticket already but if I can save the extra ticket on staff especially this time of year I will :)

 

Huge fan of corsair I have all the vengeance set and previously owned the 2000 headset but seem to have issues only with headsets is this just my bad luck?

 

Thanks in advance

Castodius

Link to comment
Share on other sites

Hello Toasted and thank you for the response!

Sorry I should have mentioned in my previous post that I had already tried the manual re-pairing and no luck... The led on the dongle continues to stay lit solidly no matter what I do unless I remove it from the usb slot.

Do you think the dongle is at fault or the actual headset?

I'm also currently draining the battery on the headset as we speak just for interest but I highly doubt it's a fix of any sort.

 

Thank you

Castodius

Link to comment
Share on other sites

I doubt the discharging the headset would do anything. It's possibly the dongle that is faulty. You could try connecting it to a different computer or find a way to "reset" it and see if that helps.

 

In your ticket, If you have not already, upload a picture of the invoice as proof of purchase.

Link to comment
Share on other sites

Hey again :) tried on another pc and no luck. I'm not entirely sure how you mean by resetting it... Is there a way? I figured the battery drain would be a no go but I figured I would try anything and everything to be sure.

I didn't think of adding my receipt to the ticket and will do so thank you Toasted it's great seeing people still out there willing to offer their help and support! Hats off to you sir ;)

Regards

Castodius

Link to comment
Share on other sites

Unfortunately, i don't think there is a way to "reset" the dongle. You will need to wait until January 2 (California time) when Corsair gets back to work to resolve the issue.

 

If you are still in warranty (two years from purchase date), they will send you a replacement dongle for you to try.

 

If you are not in warranty, you should be able to buy a replacement from them.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...