Jump to content
Corsair Community

M95 Stupid Question?


Recommended Posts

Hi there!


I've never had a super complicated mouse before, my previous mouse is the Corsair M45. Which I love, however I wanted a second mouse to replace this as I felt like I was overdue and upgrade. Bought myself an M95 Vengeance for Christmas however I've hit a few teething issues. (Or just me being a complete moron issues)


Basically when I plug in the M95 and let it auto install it works okay as long as i'm using 1 program, however when I say minimize this window i'm typing in, it won't let me select the program on my explorer window. - It seems to lock to one program at a time, which is an issue with me as I run many games at the same time and am constantly switching between them. - The way I fix this is to alt tab to the program or to get to task manager before i'm able to use the explorer bar again.


I also have an issue where it believes the middle mouse button is pressed in, upon clicking a tab it closes, and opening new links opens them on new tabs.

Weirdly I only seem to have this problem on my PC, as I've tried it in my laptop and the 1st problem still occurs but this one does not. - (However after typing this it seems to have now gone away so we'll park this for now.)


I've spent a while looking online to try and resolve this issue but can't seem to find any clear answers.


I've tried installing the software and doing the firmware updates but it didn't do any good. So I decided to make this post and have a fresh start, so as it stands all I've done is plug it in and let the windows auto-install happen.


Any advice would be much appreciated as I really do love the feel of the mouse, it is certainly an upgrade to the M45, I just need to learn a few things to fix it.


Thanks in advance!

Link to comment
Share on other sites

Feels more like the M95's middle mouse key is sticking more than anything now. Even when scrolling a little it seems to activate the middle mouse button which in-turn deactivates program swapping and "sticks" the middle mouse button.


Just tried opening a game and it instantly "greyed"out, however when I used my old mouse to press the middle mouse button it fixed it... Not quite sure what is going on, would anyone recommend I send it back? OR are there ways to try fix it?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...