Jump to content
Corsair Community

SP2500 - Remote working but no sound!


SuperSouter

Recommended Posts

Just got myself these speakers and sadly not having much luck.

 

All plugged in correctly, have tried connecting via L/R to 3.5mm to Line Out on graphics card & front of pc

 

Have tried 3.5mm to 3.5mm with the same on both AUX and all results are no sound at all. The whole system sounds dead, however the remote control is working absolutely fine.

 

I have checked to see if speakers or subwoofer are muted, I have tried all volume levels. I have checked previous speakers through same line out and working fine.

 

Computer shows that there is audio signal being sent through, speaker system is not receiving any at all.

 

Please help, I have contacted the seller and they have said that they will give a refund if not working but I really want to try and get this to work and have these speakers.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...