Jump to content
Corsair Community

stuck in BIOS mode


tetsussaiga

Recommended Posts

Hello,

 

New forum member here. I've had my K70 (non-RGB) for about a year now, this problem suddenly came up a few days ago. The white leds (num lock, caps lock, scroll lock) are all flashing when I plug it into my computer, indicating I'm in BIOS mode. I did absolutely nothing that I know of to cause this. I can't seem to get out of BIOS mode making the keyboard useless. I've tried changing the polling rate/BIOS switch at the back of the keyboard to all the different settings, booting with it set into BIOS mode and then booting back into the 1 hz polling setting, Tried switching into BIOS mode and waiting 5 seconds and putting it back to 1hz, as it fixed the scroll lock flashing problem, but didn't work for me. I couldn't even find a hard reset button. I tried plugging it into another laptop, but still remains in BIOS mode. In desperation, I just tried installing Corsair Utility Engine and it doesn't recognize the device. Any other ideas or suggestions would be appreciated so much. Thanks!

 

tetsussaiga

Link to comment
Share on other sites

It shows up as 'Corsair composite virtual input device'. Is that what it normally is? The keyboard works but all the media keys, backlight controls, and even the space bar don't work. The red backlighting is off too. I read from the K70/K95 FAQ thread that num lock, scroll lock and caps lock white LEDs would flash when it's in BIOS mode.

 

I'm wondering if there's anything else I can do, or I might have to RMA it? It seems like a firmware problem or something wrong with the polling rate/BIOS switch in mine. I never touched the switch up until this problem began.

Link to comment
Share on other sites

  • 4 months later...
It shows up as 'Corsair composite virtual input device'. Is that what it normally is? The keyboard works but all the media keys, backlight controls, and even the space bar don't work. The red backlighting is off too. I read from the K70/K95 FAQ thread that num lock, scroll lock and caps lock white LEDs would flash when it's in BIOS mode.

 

I'm wondering if there's anything else I can do, or I might have to RMA it? It seems like a firmware problem or something wrong with the polling rate/BIOS switch in mine. I never touched the switch up until this problem began.

 

Hello, I have this problem just now for my Corsair K70. It is also stuck in BIOS mode and no matter what I try it stays stuck. Tried on a different computer and still the same thing. Did you happen to find a solution to your problem?

Link to comment
Share on other sites

  • Corsair Employees
Nevermind. I fixed the problem. Just did a firmware update to 1.09 and my keyboard is back to normal again :)

 

You should be on 1.20 - if it won't update correctly, contact our tech support team and they can help you with it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...