Jump to content
Corsair Community

Corsair Link doesn't recognize my H100i


Recommended Posts


I have a big problem with Corsair Link: it doesn't recognize my H100i.


I tried everything: to change USB port on the mainboard, to reinstall Corsair Link, to install another version, to disable USB Legacy in BIOS settings, but nothing... H100i does not appear in Corsair Link devices.


Some months ago, with another version, the H100i was correctly recognized by Link... but not now.


I'm desperate, I don't know what to do... can someone help me, please?

I would be really happy if I resolved the issue...


Thank you very much, and I'm sorry if this is one of a lot of similar threads... but I really don't know what to do to get this matter resolved.

Link to comment
Share on other sites

Is the H100i detected in Windows?


If you have it connected via a USB cable, You can check by going to Devices and Printers then look for "Integrated USB Bridge".


Yes, H100i is detected in Windows.

I have an "Integrated USB Bridge" in "Unspecified" section of Devices and Printers.


EDIT: I re-tested all the latest versions of Corsair Link, and the only one that recognizes my H100i is the BETA Version 2.5.5145... why the further releases (like the 2.7.5361) can't detect my H100i?

Link to comment
Share on other sites

This might be the issue.


Have you also tried updating your BIOS and chipsrt drivers?


Known Issues

On certain Intel motherboards (Z87/Z97) that use the Intel USB 3.0 drivers it is necessary to change the “Legacy USB Support” to Disabled in BIOS for detection of the H80i/H100i/Commander units.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...