Jump to content
Corsair Community

K70 RGB Keeps Freezing


iMiniBiscuits

Recommended Posts

So every time i turn on my computer my keyboard lights with the red and white default up as expected. Once i log on, it changes to the profile i had it on the last time i used my computer (This is a rainbow of colors moving from left to right in a wave) It works and i can use it for about 2mins and then the rainbow stops moving, (the brightness and windows lock button wont work when this happens) if i restart my computer the same process happens again, at the same point every time. I'm not sure whats wrong and i have even had help from a k95 owner, and he hasn't done a great deal. :sigh!: Please help

 

 

Thanks

 

 

-Mini

Link to comment
Share on other sites

So every time i turn on my computer my keyboard lights with the red and white default up as expected. Once i log on, it changes to the profile i had it on the last time i used my computer (This is a rainbow of colors moving from left to right in a wave) It works and i can use it for about 2mins and then the rainbow stops moving, (the brightness and windows lock button wont work when this happens) if i restart my computer the same process happens again, at the same point every time. I'm not sure whats wrong and i have even had help from a k95 owner, and he hasn't done a great deal. :sigh!: Please help

 

 

Thanks

 

 

-Mini

 

It's happening to me since release. It works for 5 mins then freezes. If I dont touch keyboard it's fine, it's messes up after use?

 

I'm getting sick of waiting for a fix. I'm looking at the razer....

Link to comment
Share on other sites

So every time i turn on my computer my keyboard lights with the red and white default up as expected. Once i log on, it changes to the profile i had it on the last time i used my computer (This is a rainbow of colors moving from left to right in a wave) It works and i can use it for about 2mins and then the rainbow stops moving, (the brightness and windows lock button wont work when this happens) if i restart my computer the same process happens again, at the same point every time. I'm not sure whats wrong and i have even had help from a k95 owner, and he hasn't done a great deal. :sigh!: Please help

 

 

Thanks

 

 

-Mini

 

Can you list every component of your PC and everything plugged into your PC via USB?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...