Jump to content
Corsair Community

Voyager mini 32 Gb issues


Seoks

Recommended Posts

Hi! Sorry for my bad English.

I`m buy Corsair Falash Voyager Mini 32 Gb in Moscow, now I live in other country Ukraine, Kirovograd city. I use this flash 3 month and flash broken - XXXXXXX U167 CONTROLLER USB Device in device manager, the drive does not appear in My Computer at all.

Serial:

000244A 32G CHINA

11226018 1301423516

I`m lost data, and very sad :[pouts: :sigh!:

Corsair please help me, I need a working Corsair flash drive...

Link to comment
Share on other sites

  • 4 months later...

Hi there

 

I have exactly the same problem with my Corsair Flash Voyager Mini usb drive. The only difference is that my capacity is 16GB instead of 32Gb.

 

The Flash Voyager Mini is now recognized as "XXXXXXX U167 CONTROLLER". It is unformatted and totally unaccessible. My data is now most likely finally gone... :[pouts:

 

Well, around the Internet there is available a repair tool called "Pen Drive Repair.exe". It seems to have the capability to repair "U167 CONTROLLER" based flash drives. Some users claim that this tool worked perfectly. Only difference is that the Voyager Mini will have after the repair different device name.

 

Is this way to fix that error recommended and secure? Or is it better to send the defective Flash Voyager Mini trough RMA back to Corsair? What's Corsairs position of this workaround?

 

UPDATE 09.05.2015

The mentioned "Pen Drive Repair.exe" loads a stock firmware onto the Corsair Voyager Mini. The flash drive is now again accessible, - but completely empty, ALL DATA is definitely lost!

My conclusion: You cannot use these repair tools for recovery, - by loading / programming the stock firmware, these tools will wipe out all present data finally!

Link to comment
Share on other sites

Many thanks for this fast answer!

 

Ok, - I have tested the tool. It seems that it has loaded a stock U167 CONTROLLER firmware onto the Corsair Flash Voyager Mini USB drive. Although it is now again accessible, three is NO DATA on it. :(:

 

I try to recover some of my data with TestDisk 7.0 & Photorec utility. But they doesn't find anything. Well, I have some backups and the other stuff is lost. That's life. ;):

 

So what I can say, - you cannot use these "repair tools" for recovery. It is possible to use these "repair tools" to make a U167 CONTROLLER based flash drive again usable / accessible. But if the error is really fixed is another question, - it is possible that the same error occurs again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...