Jump to content
Corsair Community

AX1200i weird issue


min91

Recommended Posts

It seems my new psu won't turn on if the 10-pin from the ATX 24-pin is plugged in to the psu (even if the cable doesn't plug into any components). There's no problem with the self-test button. It gives the green light when it's not connected to anything and it also gives the green light when it's connected to my video card, hard drives, and fans.

 

At first I thought it was the motherboard so I unplugged the 24pin from the motherboard and kept the cable still plugged to the psu but the problem persisted. Then I thought it was the 24-pin cable that was causing the problem so I tried my non-sleeved (stock) cable and it still wouldn't turn on. Weird thing is it will give me the green light if I plug in the 14-pin and keep the 10-pin unplugged.

 

Every one of my builds have all turned on and worked fine from the first attempt and this is the first time it didn't. I've dreaded this day would come. Do I need to RMA my psu? :(

 

Update: It also turns on if I unplug the 14-pin and plug the 10-pin. So it just doesn't work if all 24-pins are connected to the psu (regardless of whether or not the other end is connected to a component).

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...