Jump to content
Corsair Community

How to recover an H80 after CL 2.7.5361 bricked it


Recommended Posts

How do I recover the firmware in an H80 after the :evil: CL 2.7.5361 program bricked it?

When I ran CL it offered to upgrade from 1.1.12 to 1.2.8. I said OK, the upgrade started and then failed :mad:. After the failure CL either no longer detects the H80 at all or detects and unknown device, offers to recover it and then promptly crashes :(:! I have the H80 connected via a CL Mini with the 1.1.6 firmware.


All in all CL really seems rather unreliable. Is there any other firmware up-loader/recovery tool that actually works that I can use?

Corsair, Please may I have the firmware upload protocol specification so I can write a reliable firmware updater?

:eek:. Note that throughout this attempted upgrade no other software was accessing the CL hardware as I am all too well aware that CL fails to use a mutex to interlock accesses with 3rd party applications


Link to comment
Share on other sites

I had a similar experience to this which resulted in my H80 being RMA'd probably not the answer you were looking for! Link also bricked my cooling node which I managed to recover doing similar steps to this post




I did once manage to get the H80 in recovery mode but it wouldn't take the H80 firmware I had. It said it was the wrong version and I couldn't find any other firmware for it. It also wouldn't get the firmware from the net. In the end I raised a ticket with support and they arranged to replace it. A bit of a pain having to RMA but I can't fault the RMA process it was smooth and effort less.

My H80 was still cooling the CPU normally after it was bricked just the fans were on full all the time and I managed to keep using the PC and get a new H80 sent to me before I sent back mine which resulted in very little downtime. Overall excellent service from Corsair!

Link to comment
Share on other sites

Thank you for the information. I can manage to get the H80 into recovery mode, but when I do this both CL 2.7 releases fail to reload the firmware. I also tried CL 2.6 but that seems to get confused by my CL Mini which I guess is too new. I too suspect I will have to either RMA it, return it for a refund (as it does not work) or write my own firmware loader program. I have already raised a ticket with CL support and am awaiting a response.
Link to comment
Share on other sites

  • 8 months later...

When the firmware update failed the H80 was connected via a CL Mini (CLCC). I now also have an old silver commander and yesterday with an H80 connected via that I successfully updated the H80 firmware using CL 3.1.5667. I am currently wondering if H80 firmware update worked for others via a CLCC. If this worked for you it would be good to know. Knowing the situation for an H100 should also provide some insight.


I could try again updating the firmware via the CLCC, but am reluctant to do the experiment for obvious reasons.


The main reason I am wondering this is that CL 3.2.5676 totally fails to report any of the hardware I have attached via my old commander :mad:, so I am wondering if I will ever be able to use the old commander with new CL releases. I know the hardware is OK as CL 3.1.5667 reported it before I updated and SIV also still reports it.


Only the H80 and H100 (V1 protocol) are of interest as the H100i and H80i use the V2 protocol. Note the old commander also uses a V1 protocol but the CLCC uses the V2 protocol.


I have only ever had an issue with the H80 and CLCC when doing the firmware update. I currently have 2 x H80 connected via a CLCC and the hardware works well.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...