Jump to content
Corsair Community

problems with corsair control panel audio program


Recommended Posts

so it never worked for me, every time i opened it it just was all white and says program doesnt respond.


today i found this new update 3. something and i installed it, for the first time i could actually use the program and the 7.1 was quite good since by default it always used the stereo 2.0 and i couldnt change it.


after i rebooted my pc the program did the same like before, all white, program doesnt respond, and now im again with stereo 2.0


i´ve had tons of issues with corsair and i see tons of threads with just problems, im not buying any coirsair product on the future since they seem to be crap cuz a big mayority of the customers have issues but atleast help me out with this since i bought your god dam headphones...:mad:

Link to comment
Share on other sites

Corsair's official support channels are through the support ticket system or by calling Technical Support via phone. There are also Corsair employees who regularly help with issues in the forums as well.


A list of them are here



Check Event Viewer and see if there are any entries related to the software which may help with resolving the not responding issue.

Have you tried a different USB port?

Latest BIOS and chipset drivers?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...