Jump to content
Corsair Community

Discuss Link Release Candidate v2.7.5361 here


Recommended Posts

  • Corsair Employees

This will be the official discussion thread for Release Candidate Version 2.7.5361.


Here's where you can get it.

Please Note you must delete any saved Profiles and uninstall the old version and reboot the system before you install the latest software.

  • Uninstall the Corsair Link software through Windows Control Panel
  • Go to file explorer, enable "Show hidden files, folder and drives"
  • Delete the following directory: C:\Users\"System name"\AppData\Roaming\Corsair
    (This directory is also used to store custom profiles for other Corsair products. You may want to save this directory on a different location so you won’t lose other profiles)
  • Restart your system
  • Install the new Corsair Link software


9/30/2014 - Corsair Link Software Update Release Candidate Version 2.7.5361


Change Log

  1. New firmware for Commander Mini (1.1.6) addressing thermistors not showing up.
  2. Changed “Check for Updates” process to show a dialog box stating all firmware is up to date instead of updating already up to date firmware on all devices.
  3. Updated “Contacts” section with working links to support and the main page.
  4. Addressed the icon positioning on the main tab when the window is resized so that icons do not end up outside the window.
  5. User should no longer be prompted to save the profile if no changes were made.
  6. .exe is now digitally signed.
  7. Tooltips settings are now saved and can be turned off.


Known Issues

  1. LED saved settings not persistent after restart if two of the colors are set to 0 (255, 0,0) New firmware revision to address issues will be available in a 2.8 release.
  2. On certain Intel motherboards (Z87/Z97) that use the Intel USB 3.0 drivers it is necessary to change the “Legacy USB Support” to Disabled in BIOS for detection of the H80i/H100i/Commander units.
  3. Compatibility - NZXT CAM driver package conflicts with AXi Series drivers needed for communication with the PSU.



If you'd like to report a bug, please respond to this thread in this format:


  1. Version of your Link software. NOTE: If you're not using v2.7.5361, please install it and see if the bug has been fixed.
  2. What version of Windows you're using.
  3. Summary - One line / sentence explaining the issue
  4. Detailed description of the issue - This part can be as long as you want. It should be detailed enough so that we can clearly identify the issue and attempt to replicate it.
  5. Attach photos of the issue to the post that help #4.

Link to comment
Share on other sites

  • Replies 222
  • Created
  • Last Reply

1. 2.7.5361

2. Windows 8.1 Pro 64-bit


AirFlow Pro shows everything as 0 via Link software (attached to Commander Mini).

This has never worked at all.

If I look into my case, however, I can see the LEDs are correctly indicating the status of my RAM (blinking and changing color with temperature etc)

Link to comment
Share on other sites

1. 2.7.5361

2. Windows 8.1 Pro 64-bit

3. Ax1200i and Cpu temperature are Flashing Red and then reporting for 1-3 sec and repeats al the time


Ax1200i is with the Usb header on the motherboard connected


i did already reinstalled the software

Remove old version

remove user/appdata/roaming/corsair







i7 2600k

asus p8p67 deluxe

Corsair 16gb 1600hz



2xAsus 770 Dc2oc



P.S. i have installed 2.7.5339 and everything is working normal again. Since Sli isnt working on last version i will stay with the older one for the moment



Link to comment
Share on other sites

Version Software: v2.7.5361

Windows 7 Ultimate 64

Does not detect pump, fans and sensors with no problem. Sometimes shows the temperature and sometimes not.

Problem since the other versions, I believe occurs from v2.5


Please help me




Link to comment
Share on other sites

not updating until this is fixed.


On certain Intel motherboards (Z87/Z97) that use the Intel USB 3.0 drivers it is necessary to change the “Legacy USB Support” to Disabled in BIOS for detection of the H80i/H100i/Commander units.

Link to comment
Share on other sites

No H100i Temp detection in this version. just reads 0.0 temp, all sensors and fans detected otherwise.

No control over any of the fans, stuck on quiet mode, just had my CPU in High 60s thanks corsair nearly fried my CPU, back 2 versions at least that has no memery leak and can control fans, software hangs after 10 mins, no context menu control and no software control at all.

Win8.1 x64

Link to comment
Share on other sites

1. Version 2.7.5361

2. Windows 7 Ultimate x64


3. In order for custom profiles to run correctly for me, Corsair Link Software must be set to "start with windows." (This might be by design though, so I have it set to "start minimized")


4. Because of Number 3 above, I have two requests; (I'm sure I'm not alone here)


A. Can we not make Corsair Link Software launch discreetly with windows? We don't need to see the "logo pop up" every time windows desktop is started. Its intrusive.


B. Get completely rid of the notification that "Corsair Link Software is still running" when minimized. It is Pointless and intrusive. Again, we have to see that every time windows desktop is started, when it is set to start minimized.


Thank you!

Link to comment
Share on other sites

1) v2.7.5361 - I replaced the digital cable from the AirFlow Pro with a new one to my Mini and now Link reads it.

2) Windows 8.1 Pro-64 bit and Commander Mini:

(4 Case temps-Ok, 5 fans-OK (4 Case fans, 1 Memory fan), 2 digital connections: #1 Digital Connection=PSU-Ok; #2 D.C.=Memory Temp & Activity-Ok.

3) One bug for my 4 drives:

Displays my temps for the SSD, the Seagate HDD, and one WD Black 2TB HDD; but does Not display my 2nd WD Black 2TB HDD, not in raid, just the same model/part number. I am planning to buy 2 more (all the same part number, so I will need the temps of all 4 eventually.

4) LINK v2.7.5361 DOES PROPERLY DISPLAY the following (in the Link System Tab display-See attached picture):

-Thermister Temps; all fourdisplay

-PSU Fan & Temp display in both System and Power Tabs

-Case Fans & Memory Fan -All display

-H100i; the Pump, the LED, the Water Temp, and all 4 radiator fans display

-Mini Light strip LED's display

-Memory Temp & Activity display

-SSD temp displays

-HDD's (3)- Two of 3 display (see "3) bug" above)


Thank you this Link version. I am now happy, almost joyful, after futzing with the Link for over a total of 100+ hours, I replaced every link cable, Molex plug, etc. with all new cables and plugs now Everything displays but one of my drives. Good Job!


Update: 2015-01: I shut down this PC's power completely when I went on vacation. When I returned and powered up, the link was missing my HD's temps. I uninstalled the link, deleted the proper "roaming" folder, rebooted, re-installed the Link, and everything was back to normal again. It still has never shown my 2nd WD HDD. Why does the Link recognize my WD D: drive, but not my WD E: drive (same WD part number)?


Link to comment
Share on other sites

2.7.5361 bug(s)


1. Windows 8.1 Pro x64.

2. Temp readings incorrect/missing on CPU and H80i.

3. CPU temperature sometimes jumps up and shows as ~30C something. H80i temp never seems to be anything other than zero. Uninstalled according to instructions (v2.7.5339 worked fine for some reason btw).

4. Attached image:


Link to comment
Share on other sites

Windows 8.1 Pro 64-bit


Uninstalled, cleaned appdata profiles, cleaned registry...


Same issue as before: icon tray not loaded at all although corsair link is in memory. Every other icon loads fine in the tray.


EXCEPT now there are some more issues regarding the sensors: H80i Temp sensor shows red flashing 0,0ºC all the time, so does the CPU temp (red flashing 0-goes white with right temp-red flashing 0-goes white... etc). Some of the MOBO sensors are doing the same.


So far, this is worse than the previous version.


One positive thing: check for updates feature shows no firmware updates. Nice (already updated thousands of times to 1.0.7)


More fixes? I personally will rollback to previous version. At least all sensors worked even with the missing tray icon thing.


EDIT: It seems the custom curve thing is working although H80i Temp is not shown. Fans spin up and down when temperature rises. WTF.

Link to comment
Share on other sites

1) 2.7.5361

2) Windows Technical Preview Build 9841

3) No devices are showing at all

4) Previous version showed all devices at 0, now this version doesn't detect any devices at all. Only occurred since update to Windows Technical Preview.



Link to comment
Share on other sites

I am also running Windows Technical Preview and Corsair link detects no devices. I have installed and reinstalled and tried different versions.


The problem seems to be that the hardware monitor does not load at all because CPUID is marked non-compatible.

Link to comment
Share on other sites

Hi there,


I lost count on ho many times I (un)installed the software (even older versions), restarted my computer and changed USB port. (Clean Windows Install)


Personal Issues:

- Notification that Link is running... (who cares, we know it right. People who are using Link software aren't beginners)

- Showing Link logo on startup... (It's simply a no-go)


Technical Issues:

- H100i temp stays at 0

- CPU temp blinking red in and out (showing true temp/ showing 0 temp)

- LED H100i stays green... doesn't change color, besides "black"

- Not all temperatures showing of motherboard


EDIT: It looks like the temperatures of the motherboard, CPU and H100i are shown in the contextmenu, but not in LINK




- Asus Z97 Pro (WIFI AC)

- INTEL 4790K

- H100i

- Windows 7 x64

Link to comment
Share on other sites

No, the Commander Mini is not the LINK USB Dongle included with the AXi PSU.


The Commander Mini is basically an updated version of the Corsair LINK kits. It allows you to plug four temperature sensors, six fans, one L.E.D. strip/channel and a total of 4 other LINK compatible devices in a size similar to the first generation Cooling Node.


Product page for the Commander Mini is here.



The address to the firmware file is not an internet URL, it's a reference to locate the firmware update file for the firmware updater. I've edited it so it should prevent confusion.

Link to comment
Share on other sites

Hey guys! FYI I had the same issue with the H100i not showing temps or detected. Do you have an Asus Motherboard? In order for me to get that to work all I did was disable Temp Probe and the temp sensor in Asus Suite and it worked. Now I just have the issue of not seeing Fan RPM's on the Rad.


Update: Jesus guys I'm gonna burn my SSD out with all this uninstalling, re-installing. I can't believe after all this time this software is still in limbo. I'm really getting annoyed by this. I've just updated to new version in hopes of seeing the fan RPM's and having control of them but NO. Now I can't see temps on H100i and the fix above does not work. Why the hell is this cheap software even released? It doesn't work. But keep pushing those units with faulty software................see where that gets you. Doesn't seem like anyone gives a RATs *** either. Now I gotta uninstall, delete, reinstall, uninstall, delete, reinstall to the older version and cross my fingers. I'm ready to toss this garbage to the side for something that works and not have to play with it. Geez I'm mad.

Link to comment
Share on other sites

Someone should make a program that just controls the H80/H100 pump and fans and nothing else basically. Corsair Link is bloated, uses too much CPU (this version at least) and crashes too. (See my old post for more info here).



Me and WizzyThing are working on an alternative to Corsair Link. It is still in development. If you know anyone who can help: https://github.com/Doridian/CorsairLinkPlusPlus

We might actually start a public beta sometime soon.

Link to comment
Share on other sites

I have had the H100i for almost a year now, and one of its main selling points was the software that goes with it, when i first installed it i had to modify the register but it worked somewhat, sure not everything showed but the main reason to control the fans and pump did, i thought he its not out that long i am sure it will be fixed soon ( i got to say i never really read these forums just sought for a fix and it worked and went on my way)


Now fast forward to today, i have to do a fresh install on windows 8.1 64 pro and i go back to download link, after installing it shows me almost my entire system but still NOT my h100i fans and pump, it is the only reason why i use this program to begin with, now i dove into these forums and it is simply depressing it seems to me that almost nobody can get the damn software to work ?


Anyway after a clean windows 8.1 install with no other programs or anything else installed i had to do the register modify again, it somewhat works again now but my processor temps are glowing red and on 0 and then reading the actual temp again and i have a fair few other issues with it as well that are well documented in these forums (2nd gpu not showing up, the led not remembering its color, i can go on for a while but you get the picture) i understand that it is cool to have software to control everything but really i just want to control my h100i and nothing else.


Corsair link is an ambitious program but at some point you guys just have to admit that it was too ambitious for the guy you hired to do it and just let all the extra stuff go, and just prioritize that we can actually use your hardware with the provided software and not be driven to half insanity by trying to use your software as it is now, a peace of bloated software that tries very hard to do many things but actually does nothing right.


TLDR: If i knew back then what i know now i would never have bought the H100i, Corsairs hardware is fantastic but there software is beyond saving.


Edit: i was planning on buying a k70 RGB but after reading those forums i nope'd out of there and decided ill probably buy another keyboard

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...