Jump to content
Corsair Community

Force GT not detected in BIOS


Recommended Posts



I have Corsair Force GT 120GB for 2 years and it's configured as my boot drive. All of sudden I can't boot into Windows because the drive is not detected anymore.


It's working normally until the last time I shutdown my pc around 5AM, but when I powered my pc around 8PM the same day, the problem occured. I have switched the power and data cables from other drive, check for loose connection, tested it on another pc, it's still not detected.


The ata controller in bios is set on AHCI, and it's like the controller takes longer than usual to scan the drive and then finally failed to find the ssd. If it's helps, I can see a glimpse of red light coming out from ssd, the unit also a little bit of warm so I guess at least one of the components working.


I googled around and find firmware might be the issue, I also experienced firmware problem with my M65 mouse

That stopped working suddenly but solved after I flash the firmware. Well since the ssd not detected in BIOS and of course I cant log in to Windows. I dont know how to that.


Since it's my boot drive and a lot of my important data is in the drive, I will appreciate any help for the problem.



Link to comment
Share on other sites

  • 4 months later...

This issue appears to be related to sleep issues. Did you put your pc to sleep? This has happened to me two times now! The first time, my system BSOD from sleep. I figured my Corsair crapped out on me, so I removed from my pc and just ran on my slow HDD. About six months later I decided to try and revive my Corsair SSD, and I was able to set it up as a gaming drive.


Six months later I upgraded my video card and power supply. This time, feeling confident that my Corsair SSD was working fine now, I made it my boot drive. (Big Mistake!) So today I put my computer to sleep, woke it up when I got back home, and whamo BSOD.


My BIOS doesn't recognize the Corsair SSD. My Patriot SSD is recognized fine. I have tried unplugging, and switching ports for it to no avail. I tried enable Hot Plug, and made sure quick boot was disabled along with Intel quick start. I am at my wits end trying to figure this out. This will be the last time I ever buy Corsair.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...