Jump to content
Corsair Community

K70 LEDs not working


Recommended Posts

So i bought the K70 in black (Red LEDS) about 8 months ago now. A few days ago i noticed that only 123456 WASD and the arrow keys are lit up. I pressed the key that changes them from full keyboard backlit to WASD only ect and nothing changes. I hold down the key and usually a red ring comes up and you can set custom keys to be lit but nope nothing.


I've uninstalled and reinstalled drivers, played with all the profiles and nope nothing. All the keys still work perfectly but the lights just refuse to cooperate.


It's had nothing spilt on it, the only thing i have done is change the WASD and 123456 keys to the grooved ones with a grippy texture on them that came with the keyboard.


Anyone had this problem?


FYI it has had nothing spilt on it ever. I have tried changing USB ports also the USB port on the Keyboard next to the profile switch worked once and never worked again.


Also should say when i open the Corsair Gaming Software that a box pops up saying "No device detected please connect a device"


I would like to just add ANOTHER detail. I just reinstalled the firmware and all the keys lit up once it was done for roughly 30 seconds. Then turn't off again and left me with said keys above..... i'm at a dead end here.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...