Jump to content
Corsair Community

Corsair K60 Completely Bricked.


Recommended Posts

So I bought a Corsair K60 from amazon less than a month ago. I've used it since then on pretty much a daily basis. Over that time it would randomly disconnect, but would reconnect after a short time, so I didn't think too much of it.


Then today, it disconnected again. Only this time it didn't reconnect. I tried plugging it into every single USB slot on my PC, front and back. No dice.


It is definitely the keyboard, as these USB ports are definitely working, I tried them with other things.


I have tried the firmware updater but I was met with this error(I ran it both normally and as an admin, and was met with the same message




I would really like to know what the problem with this is. I paid hard earned money for this expecting it to last longer than a month.


Oddly enough, there IS power going to the keyboard. The num-lock light is showing up, but none of the keys are responding.



So I've reinstalled multiple drivers, including the keyboard's driver, USB drivers, everything. No dice.


I've determined that it's definitely the keyboard, since I'm using another keyboard right now on the same PC.


I truly do hope that there is a way to fix this. It was very hard to be able to afford this and it was a treat to myself. I'm also not exactly in a position to ship it anywhere

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...