Jump to content
Corsair Community

Issue with my new Corsair RGB


Dredge

Recommended Posts

So I am not sure how to best explain this.

 

My keyboard worked fine for an hour or so, was messing around with lighting options. And I put my computer to sleep, and when I woke it up all my issues started occuring.

 

Firstly the LEDs seem to freeze until I change the BIOS switch or unplug and re plug the keyboard. After I do one of those it works for a whole 5 seconds before it does it again, this is very frustrating because I cannot enjoy this keyboard.

 

The keyboard works fine but the LEDs are messed up, every single one freezes, including the small LEDs for caps lock num lock and scroll lock on the top of the keyboard.

 

I also cannot use the brightness button located on top of my keyboard to turn the LEDs off or modify the brightness. I am guessing it is an issue with the keyboard communicating with the software since typing on the keyboard works flawlessly.

 

Hopefully this can get resolved ASAP. :)

Link to comment
Share on other sites

Make sure the keyboard has both USB connections in the USB 2.0.

 

It will not function properly, at this moment, in USB 3.0 ports.

 

They are plugged into USB 2.0 ports directly on the motherboard, although I have tried the ports on the front as well.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...