Jump to content
Corsair Community

K70 RGB list of users with issues


Anorax

Recommended Posts

This problem seems to be limited to when I'm using the keyboard in Ubuntu 14.04: the zero key is output every minute or so (without my having pressed it).

 

UPDATE: Actually, this is happening in Windows as well --

 

My Specs:

  • AMD FX-8350
  • 32GB Corsair Dominator Platinum RAM
  • EVGA GeForce GT 580
  • Corsair SSDs
  • Corsair 1050 PSU
  • Advanced Report attached

report.txt

Link to comment
Share on other sites

I've updated the list. My main aim of the list is to highlight the device detection issue to Corsair support staff. I feel this is THE number one issue at this time as it effectively makes the software useless. I did consider Google Docs but this is open to abuse when opened to public.

 

I am hoping this list will be obsolete soon if and when Corsair releases updates to fix the device detection issue. In the meantime it is a good indicator of the current problem and shows a good cross section of late model motherboards having issues.

Link to comment
Share on other sites

I have quite a few issues with mine. Here they are as follows:

 

-Lights don't turn on until logged into Windows (common problem from what I can see, but I'm not too upset about it)

 

-Pressing caps lock key in succession will cause the lighting to freeze. This is really irritating because sometimes when I type I accidentally press the caps lock and I have to press it again to deactivate it and then the lighting will freeze and CUE will simply say "device malfunction". So I have to unplug the keyboard and plug it back in to get lighting to work again. The keyboard will still send keypresses to the computer though.

 

-Lights don't turn off when computer is put into sleep mode. It does looks kind of nice though to see your keyboard's pretty lights when your computer is asleep. But it's not so great when you can't wake your computer up with the keyboard. The computer won't respond at all to keypresses to wake it up so I have to use the mouse to wake it up.

 

Those are the main problems I've experienced with this keyboard. My specs are listed on my profile.

Link to comment
Share on other sites

I just tried tapping the cap lock key in succession and I could replicate the error you mentioned with the device malfunction popping up. Corsair should take note of it. Anorax should also include it in the error/issues lists.

 

I've recreated this problem on my keyboard as well when the software is installed. Without the software no problem at all. I would say the CAPS LOCK issue is related to the same device malfunction problem brought on by changing profiles on the keyboard.

 

This all points to the software losing connection with the keyboard because of the device detection issue.

 

Corsair techs have you recreated this issue inhouse yet? Is there any progress update you can give us?

Link to comment
Share on other sites

I have quite a few issues with mine. Here they are as follows:

 

-Lights don't turn on until logged into Windows (common problem from what I can see, but I'm not too upset about it)

 

-Pressing caps lock key in succession will cause the lighting to freeze. This is really irritating because sometimes when I type I accidentally press the caps lock and I have to press it again to deactivate it and then the lighting will freeze and CUE will simply say "device malfunction". So I have to unplug the keyboard and plug it back in to get lighting to work again. The keyboard will still send keypresses to the computer though.

 

Lights don't turn off when computer is put into sleep mode. It does looks kind of nice though to see your keyboard's pretty lights when your computer is asleep. But it's not so great when you can't wake your computer up with the keyboard. The computer won't respond at all to keypresses to wake it up so I have to use the mouse to wake it up.

 

Those are the main problems I've experienced with this keyboard. My specs are listed on my profile.

 

I've noticed the caps lock causes it some of the time, but even if I spam it for 2 minutes on another computer no issues or malfunctions. Really weird issue, but I am holding out hope that Corsair can fix this without having me RMA.

Link to comment
Share on other sites

I am wondering if anyone else had the same error in the event viewer after pressing the cap lock key.

I had 20 of these pop up Circular Kernel Context Logger" failed to start with the following error: 0xC0000035 right after Device Malfunction had occurred.

Please see the attached. Maybe some use to Corsair to check if there is any correlation to the Cap lock error. After I rebooted the errors never showed up again.

1328363646_KernelErrorReport.jpg.789fb8668b6b17b435f90a4355597ae6.jpg

Link to comment
Share on other sites

Yesterday, I was testing out my keyboard.

It went crazy on me.

 

1. Caps Lock indicates it's on, but when I type, it's not in caps. And when it indicates it's off, when I type, it IS in caps.

 

2. Everytime I type, the lights on my keyboard goes into a "Brightness switch" mode. Meaning, for each key I press, it will be like Level 1 brightness, Level 2 brightness, Level 3 brightness, turns off and the process repeats.

 

3. I've tried uninstalling the software and see if it will help, after uninstalling, I restarted my PC and my keyboard won't work. Tried all of the BIOS switches but none worked. Can't type, can't do anything.

 

4. My keys will randomly start activating/typing and do really random stuffs. (It was happening about 1AM over where I am living. Kinda freaky.)

 

5. It messed up my .dll or something (I need to find the picture in my phone in order to add on the details.)

 

I have to plug in and out a lot of times.

This is my first mechanical keyboard and I love the feel of it.

I got the lights lighting up on rainbow profiles I found here for the first day it arrived but this is only my 2nd or 3rd day using the keyboard and I have it going all crazy on me. (It didn't even total up to 3 - 4 hours of usage as I get home really late from work.)

Is there any solution to these?

Link to comment
Share on other sites

Hey guys! Just got my K70 RGB today. Super stoked, except one thing...The LED of my Insert key seems to be messed up. No matter what color I set the keyboard to, the Insert key is always a different color.

 

For example, if I set the whole keyboard to red, the Insert key will be a very very dim red, almost like if the light was turned off on that key.

If I set the keyboard to yellow, the Insert key is fully lit green.

 

I don't think this is a driver or software issue. Though the software is a whole heaping mess of confusion, and I can't find a load defaults button. I'm really bummed if I have to replace my keyboard already for a replacement, but I guess I don't have much choice if this LED is messed up. :/

 

Any ideas?

Link to comment
Share on other sites

Thanks everyone for reporting the Caps Lock issue. I'll get that investigated.

 

@Bunxbutt: I heard of your case from the Tech Support agent you called today. We'll work with you to get that keyboard back for an analysis.

 

It's a hardware issue, upon removing the keycap of the Insert key, it became apparent that the LED of that key does not have any red, it only lights up blue and green. So Blue works fine, Green works fine, but any color that needs red looks off. I've contacted Newegg to RMA it.

 

Otherwise this is a great keyboard. My only other issue is software based, the keyboard doesn't ever seem to auto switch profiles for me when I launch specific games.

Link to comment
Share on other sites

  • Administrators
It's a hardware issue, upon removing the keycap of the Insert key, it became apparent that the LED of that key does not have any red, it only lights up blue and green. So Blue works fine, Green works fine, but any color that needs red looks off. I've contacted Newegg to RMA it.
Please work with support and RMA it to us for analysis, don't send it to NewEgg.
Link to comment
Share on other sites

Please work with support and RMA it to us for analysis, don't send it to NewEgg.

 

 

The Tech report told me to send it back to Newegg for a replacement. He said they were sold out of everywhere and I could be waiting a while before they'd be able to send me a replacement.

Link to comment
Share on other sites

I had the issue. I figured it was a USB problem with not enough power type of thing, and I have an Asus p8z77-v pro so I figured their USB slots would outp[ut enough power. Good thing I have a PCI USB card. Plugged it in there, so far NO PROBLEMS. Try other USB slots is the best bet - cards cost like $10, I suggest one for sure. Keyboard works perfect, will keep you updated.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...