Jump to content
Corsair Community

K70 RGB no lights on Boot up


greatg

Recommended Posts

:mad:Just got my K70 RGB. Installed the SW and updated the firmware. Rebooted my system and I noticed that there are no lights on the keyboard during boot. In fact, the thing doesn't light up until the Corsair SW loads up?

 

Is there a way to get lighting @ boot?

Link to comment
Share on other sites

Ok, so I was playing around this evening and this is what I've discovered:

 

1. I ensured that both KB USB connections were connected to USB 2.0 on my mother board.

2. When I booted up, no illumination.

3. Shut off main AC and unplugged KB USB

4. Plugged everything back in and booted up. KB did not illuminate until Win Boot Logo.

5. System booted and KB went into default mode. It did not go into profile saved to memory.

6. Put the system into sleep. KB illumination on - but cannot wake PC using KB

7. Shut down and restarted again - No illumination

Link to comment
Share on other sites

no lighting on boot. keyboard actually doesn't work at all until windows logon. had to get spare keyboard to get into my motherboards bios. lights remain on during sleep. pressing keys will not wake up computer.

 

anyone else having trouble with accessing bios on start-up with this kb?

Link to comment
Share on other sites

This is an issue we are currently investigating. It could potentially be a lot of issues. A temporary workaround is to see if setting it BIOS mode will allow keyboard input to register (even if lighting is off).

 

"Setting Bios mode" as in changing the switch settings on the back of the KB? Can this be done "on the fly?" Is there a procedure to follow to ensure nothing gets "messed up"

Link to comment
Share on other sites

"Setting Bios mode" as in changing the switch settings on the back of the KB? Can this be done "on the fly?" Is there a procedure to follow to ensure nothing gets "messed up"

 

Yes it can be done "on the fly"

 

If mine ever stops, i just move the switch over. Any mode works, except BIOS mode ofc.

 

If i need to boot in to BIOS, the keyboard starts off, flip the switch to BIOS mode and light come on and it starts working.

 

If anyone is having any type of software issue, freezing, or keys malfunctioning, give it a try. Flip the switch and reopen the software.

Link to comment
Share on other sites

Yes it can be done "on the fly"

 

If mine ever stops, i just move the switch over. Any mode works, except BIOS mode ofc.

 

If i need to boot in to BIOS, the keyboard starts off, flip the switch to BIOS mode and light come on and it starts working.

 

If anyone is having any type of software issue, freezing, or keys malfunctioning, give it a try. Flip the switch and reopen the software.

 

Thanks for the info. But to which setting do you "flip the switch?" Do you leave it in this position or switch back to "1"

Link to comment
Share on other sites

  • Corsair Employees
The switch is for polling rate so you can leave on 1, 2, 4, or 8. I don't recommend leaving it in the BIOS mode (it deactivates the 104-key rollover matrix) and disable a lot of the features in the software. BIOS mode is just for when you need the keyboard prior to Windows boot-up and/or have a legacy system that won't detect a USB keyboard properly.
Link to comment
Share on other sites

The switch is for polling rate so you can leave on 1, 2, 4, or 8. I don't recommend leaving it in the BIOS mode (it deactivates the 104-key rollover matrix) and disable a lot of the features in the software. BIOS mode is just for when you need the keyboard prior to Windows boot-up and/or have a legacy system that won't detect a USB keyboard properly.

 

Okay. So, this doesn't solve these issues?

Link to comment
Share on other sites

Here's how I fixed my keyboard so it lights up before Windows boots. I moved my K70 RGB from USB3 to USB2 ports. I think the issue for me had to do with the usb3 drivers needing to be loaded before they would work. Asus Sabertooth MB.

 

 

Cheers!

Link to comment
Share on other sites

Here's how I fixed my keyboard so it lights up before Windows boots. I moved my K70 RGB from USB3 to USB2 ports. I think the issue for me had to do with the usb3 drivers needing to be loaded before they would work. Asus Sabertooth MB.

 

 

Cheers!

 

Sadly can't confirm that for my system (AsRock Fatality Killer Z97 MB) ... I switched the keyboard to USB 2.0 ports as well but the lights stay off, no matter what. BIOS mode doesn't help either.

Link to comment
Share on other sites

Here's how I fixed my keyboard so it lights up before Windows boots. I moved my K70 RGB from USB3 to USB2 ports. I think the issue for me had to do with the usb3 drivers needing to be loaded before they would work. Asus Sabertooth MB.

 

 

Cheers!

 

That does not work with my Gigabyte motherboard either

Link to comment
Share on other sites

hey folks, finally got the RGB K70 installed. So far, KB functions ok, cept at bootup. Here's what I did on install.

 

1. d/l the new CUE software and firmware files.

2. I then uninstalled all my logitech g510 software and drivers...rebooted

3. checking device mgr, logitech was just showing keyboard. I also noticed another keyboard showing, upon checking it was the corsair k70 drivers.

I had not installed theKB, just the software, hoping to learn it before release.

Not possible w/ out KB as we know.

4. uninstalled the 1.065 Cue software, rebooted

5. checked device mgr, logitech only remaining

uninstalled logitech kb drivers, then shut down computer.

6. disconnected logitech, hooked up k70 to usb 3 port(keyboard icon only)

booted computer, K70 recognized no issues. Also had default red keyboard on bootup, software NOT loaded yet.

7. I then installed latest CUE 1.48? software and 1.12 firmware. rebooted computer. This time on bootup, as all others, I no longer had the default keyboard red colors, till windows booted up or software loaded.

 

I believe either a change in the firmware, or software, has caused the keyboard to not be recognized now till windows, software and or firmware loads

 

i had default, TILL upgrading CUE software and firmware.

 

Apologies, for the lengthy post. Felt if I showed a step by step I followed to ensure clean drivers etc, might help others with functional issues. Perhaps some unseen conflicts from previous keyboard installs?

 

Hope this might help with some issues, as well as help Corsair with troubleshooting.

 

Best,

David

Link to comment
Share on other sites

hey folks, finally got the RGB K70 installed. So far, KB functions ok, cept at bootup. Here's what I did on install.

 

1. d/l the new CUE software and firmware files.

2. I then uninstalled all my logitech g510 software and drivers...rebooted

3. checking device mgr, logitech was just showing keyboard. I also noticed another keyboard showing, upon checking it was the corsair k70 drivers.

I had not installed theKB, just the software, hoping to learn it before release.

Not possible w/ out KB as we know.

4. uninstalled the 1.065 Cue software, rebooted

5. checked device mgr, logitech only remaining

uninstalled logitech kb drivers, then shut down computer.

6. disconnected logitech, hooked up k70 to usb 3 port(keyboard icon only)

booted computer, K70 recognized no issues. Also had default red keyboard on bootup, software NOT loaded yet.

7. I then installed latest CUE 1.48? software and 1.12 firmware. rebooted computer. This time on bootup, as all others, I no longer had the default keyboard red colors, till windows booted up or software loaded.

 

I believe either a change in the firmware, or software, has caused the keyboard to not be recognized now till windows, software and or firmware loads

 

i had default, TILL upgrading CUE software and firmware.

 

Apologies, for the lengthy post. Felt if I showed a step by step I followed to ensure clean drivers etc, might help others with functional issues. Perhaps some unseen conflicts from previous keyboard installs?

 

Hope this might help with some issues, as well as help Corsair with troubleshooting.

 

Best,

David

 

Thanks David! I also did a clean driver install and in my case this has not solved the problem. It seems a bit strange the k70 RGB (without the RGB) is just a keyboard and should work just like every other plug & play keyboard?

Link to comment
Share on other sites

Hey greatg, sorry didn't work for you. Hoping a clean install would do the trick.

 

Still think there is something amiss in either the new software and or the firmware update.

 

As mentioned, when I loaded the original firmware and software, I did get the default corsair k70 RGB during bootup. After updating, dark till the software loads.

 

Best,

David

Link to comment
Share on other sites

  • 10 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...