Jump to content
Corsair Community

M65 mouse not recognized. scroll wheel not scrolling up correctly


klutzo

Recommended Posts

HI there,

 

I seem to be having some problems with my Corsair M65 mouse. Now let me preface this by saying I really love the feel of the M65! Everything from the braided cord, to the weight of the mouse, and i've owned, used about a dozen mice from Msoft, Logi, Razor, etc. So love the thing!

 

It is actually still working, but there has been a specific problem which is really annoying that has crept up just in the last week or so. The scroll wheel when scrolling up seems to scroll up a few increments, then scrolls down an increment. Down seems to be fine, but scrolling up is the problem. It seems to happen on browsers, apps, etc, so it points to the fact it's either a windows problem, or hardware. I tried to install the M65wUpdate 2.26 sw-1.3 as well as the M65 setup 1.0.0.11 but both will not detect the mouse. Again it is working as a generic mouse, but will not detect as a Corsair M65. I've tried it in a couple of different USB ports as well (both usb2 and usb3).

 

Here are some details.

- Intel system i7

- Corsair 800 case (love it again!)

- Win 8.1, all updates.... updated

- lots of ram, HD space etc.

 

Thank you.

:brick:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...