Jump to content
Corsair Community

Not showing my pump, fans or led


blinx01

Recommended Posts

Ok, so basically the title sums it up.

I'm running on version 2.4.5110.

I did try the latest version but it just crashed every time on load up.

Now I have checked under Control Panel, Devices and Printers, and the Integrated USB Bridge shows up as needs troubleshooting as it has a driver issue, but when I go to Apply Fix, it runs isn't able to fix it.

Any help would be appreciated!

Link to comment
Share on other sites

As for the updated versions crashing, here is the log;

Problem signature:

Problem Event Name: CLR20r3

Problem Signature 01: corsairlink.exe

Problem Signature 02: 2.5.5145.25519

Problem Signature 03: 52a0a7dd

Problem Signature 04: Sierra2.Shared.Model

Problem Signature 05: 2.5.5144.39094

Problem Signature 06: 52a0a7d6

Problem Signature 07: 11

Problem Signature 08: 0

Problem Signature 09: System.InvalidCastException

OS Version: 6.1.7601.2.1.0.256.1

Locale ID: 2057

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Link to comment
Share on other sites

Try the latest version and see if that resolves your issue.

For the driver issue,

Have you tried reinstalling the driver by uninstalling the device from Device Maanger and allowing Windows to automatically install drivers?

Have you tried a different USB port?

Latest chipset drivers and Windows updates?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...