Jump to content
Corsair Community

K70 rgb serious malfunction..


Recommended Posts

So I received my k70 rgb today, went through all the steps for proper set up, downloaded the Corsair Gaming Software, updated the firmware, and what do you know everything works aesthetically it's just that the damn thing doesn't type. All of my media keys function properly, volume controls, etc. but I cannot type anything at all.


So my problem solving steps I've gone through are vast. I checked my device manager only to find that there are 9 items listed under Other devices all with either a question mark or an exclamation mark. Looking at the properties of these devices indicate there are no drivers installed for the selected device (Code 28). Okay..


I further went to unplugging my keyboard and replugging it into the same usb ports which are 2.0's. Nothing. I plugged them into different ports, nothing. I plugged them into 3.0 ports, nothing. I restarted my computer, nothing. Constantly having to log into my computer with the on-screen keyboard because I cannot type.


I tried updating the firmware again, same issue. I uninstalled the Corsair Gaming Software and re-downloaded the software again. Reinstalled the software, still nothing new. I downloaded a profile to try out some lighting effects to ease my frustration. The aesthetics work like a charm, lights scroll through a rainbow wave pattern with rippling effects activating when I press keys, but still nothing is typing onto my screen.


So I turn to the community, does anyone else have this issue? What else should I try? BTW, I am updating my computer specs as I post this since I had to boot up my laptop to be able to actually type again.


Thanks everyone.


**EDIT** I added the advanced report log from the corsair gaming software.

Advanced Report.txt

Link to comment
Share on other sites

Not sure if this helps but my Corsair device section looks like this:


::: Corsair devices

Device name : Corsair

Status : DeviceConnected (0x1)

Working speed : Full Speed (0x1)

Connected to : Intel® 8 Series/C220 Series B xHCI HC - 8C31

? Root Hub

? Port 3

USB VID : 0x1b1c

USB PID : 0x1b13

Hub driver : Standard, USB 3.0

Link to comment
Share on other sites

I have tried updating my USB drivers from both the ASUS website and Intel's website with no luck. I have tried flashing my BIOS to a newer version, repairing my windows installation, and although some of these things may seem unnecessary, the device manager still shows 6-9 unknown devices when I plug in the k70 rgb. I plug in my old keyboard, and that one works like a charm. I plug in the k70 rgb to another computer, works like a charm. So how or where can I find the proper drivers for my motherboard? Can anyone link me to it because I've tried numerous ones which all failed and had to uninstall. Thanks for the replies guys.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...