Jump to content
Corsair Community

RAM Test Failed (and then worked fine!)


Recommended Posts

Hello everyone,


Forum newbie alert. Bear with me!


I purchased a HP Envy locally as it was heavily discounted, and fitted my needs perfectly processor wise. I had the techs take out the unbranded RAM within, and install 4x Corsair XMS3 DDR3 8GB sticks instead. It worked perfectly for 40 days straight (it's a headless server) and then it crashed one night.


Rebooted it in the morning into the BIOS to run the diagnostics, and it complained of bad RAM. I booted into MemTest86+ and it too complained of bad RAM. It was at this point I returned it to the vendor. After we got over the "it isn't running windows?" discussion and I showed them the BIOS tests and MemTest86+ tests, they proceeded to check each stick in turn after removing them all.


They all passed with flying colours.


He was as confused as I.. so we put them all back in and ran the tests again.


Pass. With flying colours.


Anyone have any ideas what could have caused this? I take it 'bad RAM' doesn't come and go, in terms of badness? It either is or isn't? Maybe re-seating them fixed it?


It's been running fine again for 5 days so far but I really don't like "we didn't find anything wrong, and it's working again" diagnostics :[pouts:

Link to comment
Share on other sites

So many unknowns...

With the close proximity of the connection pads along the ram sticks and spring connectors in the sockets, and with the propensity of computers to be dust magnets, one hopes the 'tech' carefully cleaned or at least checked the sockets for dust and debris (that could well be conductive) that may have been disturbed by the removal of the unbranded ram before 'stuffing' in the new sticks!

Glad they're working now though!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...