Jump to content
Corsair Community

Corsair raptor m45 mouse not working PLEASE HELP


bourne1024

Recommended Posts

A couple of hours ago I bought a Corsair m45 gaming mouse.. as soon as I went home.. I plugged it in on my usb 2.0 port.. I was surprise , because it's mouse cursor doesn't response at all.. and then I thought, maybe the reason behind because I haven't install it's driver and firmware yet.. so I installed and run the said two programs... but then.. nothing happened . I tried rebooting my pc a couple of times, re-installing it's driver and firmware, switching the mouse to all of my usb ports.. and nothing happen!.. still unresponsive.. however.. windows detected the said device, corsair software also detected the mouse.. but the mouse itself is not responding to all button clicks and drag..

PLEASE HELP IM SO DESPERATE! :(

 

im using windows 8.1

motherboard : MSI 880GMS-E41 (FX)

Link to comment
Share on other sites

  • 1 year later...

So this is the bump of the century.. but I am having this exact same issue.. Was there ever a resolution? I've only had this mouse for about 2 months and it's begun to register click & hold for everything.. In fact, it's doing a click and hold without me even clicking anything..

 

I've reinstalled drivers, tried different ports, rebooted, etc etc.. Thoughts?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...