Jump to content
Corsair Community

H75 - Water pump not working


Recommended Posts



I have the H75 connected to AsRock z97X Killer motherboard and I think there is a problem with the pump unit or something.

I tried out prime95, and the temp immediately jumped to 70-80, and above, and crashes. Even with the strain from prime95, there is no additional sound coming from the water pump.

And all the fans have the same speed. I have tried to regulate fan speed in the bios, if I choose performance over standard speed, the fans go faster but the speed is consistent. They will not regulate speed.


Did I miss something when mounting? Faulty unit maybe? I am at a loss, help much appreciated!




Intel Core i5-4690K

MSI Radeon R9 280X Gaming 3GB GDDR5

Kingston DDR3 HyperX Beast 8GB

Fractal Design Define R4 Black Pearl

Samsung SSD 840 EVO 120GB OEM

Cooler Master G700, 700W PSU

ASRock Z97X Fatal1ty Killer - Socket1150

Corsair H75 Hydro Series CPU Kjøler





Link to comment
Share on other sites

Okay, so I ran the Intel Stress test and Prime95 small FTTs. The tubes did not noticeably change temps at all, they were slightly under room temp, some what cool. but under the prime95 test the computer crashed after maybe 60 seconds. temps around 68-70 C. Currently I am running everything at stock..
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...