Jump to content
Corsair Community

Commander Mini via into USB shows > Corsair Hydro H80i USB


Recommended Posts

HELP!!! So I got the Commander mini in the mail and finally had a chance to hook it up this weekend. Note, I have a H80i and AXi1200 both linked via digital link.


When first installed, it did not show up. Uninstalled software, deleted profile and downloaded the latest and greatest and everything was there until restart. Now, everything but the H80i showed up. I noticed that it showed up in the device list under commander but not in the dashboard.


Noticed an update was available (1.0.7) and decided to plug in the h80i usb to do the update. Restarted the computer. Now commander does not show up but instead it shows two H80i USB.


Did I flash my commander into a hydro? Can I change it back? check for update not working when I try to select the commander firmware.


Any suggestions would be appreciated. :[pouts:

Link to comment
Share on other sites

Tried unhooking everything did except the mini, uninstall / reinstall / delete registry / rebooting and it comes the mini still comes up as hydro USB. I think I accidentally flashed my mini into a hydro.


Found a post where another guy did the same thing and fixed it with the help of corsair IT but did not give the solution. I tried forcing the commander firmware but it errors out.


I'm running out of ideas. Probably have to wait till corsair responds to my ticket unless one of you fine people know how to flash the mini back.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...