Jump to content
Corsair Community

Corsair Raptor HS30 microphone problems


Pazode
 Share

Recommended Posts

I bought the HS30 yesterday as my previous headset broke.

I literally have to put the mic on my mouth so others can hear me in skype. Ive tried a lot of stuff to fix this but it just hasnt worked out for me. Im wondering if anyone else has or had this problem as it's very annoying and frustrating. If there is no fix ill just have to return them back and find something else :(

Link to comment
Share on other sites

  • 10 months later...

So ive been using it for the last few days, and i have found all the boosted options possible, and the mic is just super quiet again, the boom is not exactly positionable either...any advice before i take it back?

 

Kind regards

 

Tom

Link to comment
Share on other sites

  • 1 month later...
I had the exact problem but after about an hour of messing with the software, i decided to look at the cables. Turns out i hadnt plugged it in properly. I wiped the connectors and then made sure they were pushed all the way in to the slots. You should see no silver and it takes quite a bit of force to push the connectors in. This fixed the issue for me.
Link to comment
Share on other sites

  • 6 months later...

I purchased my Raptor HS30 headset about four months ago, used it a bit, then put them away until two nights ago, and now suddenly the mic isn't working.

 

After checking every possibility online and with my system, I finally tried the headset on two other computers in my house, and STILL the mic doesn't work.

 

I guess it's just a REALLY low-end product after all.

Link to comment
Share on other sites

  • 4 weeks later...

Hi Just seeing if anyone has solved this as I've already sent a ticket into corsair.

 

I have teamspeak on my mobile I managed to figure out that the low mic volume is only when using the y splitter you use to connect to the pc. If I connect the 4 pole all in one plug directly to my phone the mic is fine.

 

When I use the y splitter to connect just the mic to my phone the mic is too quiet again.

Link to comment
Share on other sites

  • 5 months later...
  • 1 year later...
Hi Just seeing if anyone has solved this as I've already sent a ticket into corsair.

 

I have teamspeak on my mobile I managed to figure out that the low mic volume is only when using the y splitter you use to connect to the pc. If I connect the 4 pole all in one plug directly to my phone the mic is fine.

 

When I use the y splitter to connect just the mic to my phone the mic is too quiet again.

 

I know I am a year late but I just bought the headset and i had the same issue.

What bigmonmulgrew says is true. But you can make it work with the splitter as well.

When i plug in the mic, it asks if its a front mic or a headset. I selected front mic and it was not quite anymore. It was the oposite, too loud and with echo.

 

In windows, when you go to recording devices you can see 2 active recording devices. One "Microphone" and one "Stereo Mix". disabling the Microphone and having only the stero mix enabled fixed the echo issue.

Now they seem to work as it should

Link to comment
Share on other sites

 Share

×
×
  • Create New...