Jump to content
Corsair Community

Corsair Link has stopped working


Recommended Posts

hi forum

So my corsair link was working fine before i went on vacation

after i came back i start my pc and as usual corsair link starts with pc, but i get a message of "corsair link has stopped working" - a regular windows message

i already tried to unistalll and install the new version but the message keeps appearing

i still can control the fans with the icon on the down right side using the 3 different modes provided but when i press show corsair link i get the error message everytime

What should i do next ???

thanks in advance

Link to comment
Share on other sites

i did delete the previous files before installing the new version

already updated .net framework to 4.5.2 but still no results, net framework 3.5 is also enabled


why from a moment to an other it stopped working i cant understand

Link to comment
Share on other sites

  • 4 months later...
For anyone still suffering from this like me I found a workaround for this. If you are still using the older software because you are having issues with the new one and now you are getting this annoying pop up do this. First I noticed at least for me even though it says CL has stopped working I just X out of the message. I do not close the software. Now if you open up the software using the startup link in the lower right it opens with no issues. Actually the software is still running fine but what I did to get rid of the message is unchecked "Run at windows start up" under options\general. Then I just put the corsair link shortcut in the start up folder. Then rebooted. Walla!!! no more pop ups. Hope this works for you.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...