Jump to content
Corsair Community

Cannot update my Voyager Air (1st gen)


Recommended Posts

Dear all,


I am writing this post because I need some help regarding the update procedure of my voyager.


About one week ago I opened a ticket with the corsair support but I did not received an answer yet.


Here's my problem:

I have a Voyager Air drive with fw version 1.2.2 and I want to update to the latest one in order to connect from my iPhone and stream files such as photos and movies. I tried to update the drive following the instructions that are found within the folder with the update firmware but when I disconnect the hard disk and switch it back on the wifi light does not blink (opposite of what is written in the instructions) and it will not update.


I tried with various firmware updates such as the 1.2.7, the 2.0.17 and the newest one, the 2.1.2 but they all give me the same problem.


Any idea on what can I do in order resolve this issue?


Thank you,

Carlo. :D:


NOTE: It is formatted in FAT32 because I need it to work on both Windows and Mac and I cannot format it since I have all my photos and documents on it and no space anywhere else.

Link to comment
Share on other sites

  • 3 weeks later...

Same here, I also have an old version 1.2.2 - running HFS but also can't update. I understood from other threads a step by step upgrade might help - unfortunately 1.2.7 and 1.2.8 are no longer available for download in the support section. Is there another place I need to look for?



Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...